aboutsummaryrefslogtreecommitdiff
path: root/utils/mariadb/patches
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-10-11 21:50:32 -0700
committerRosen Penev <rosenp@gmail.com>2020-10-11 22:14:02 -0700
commit8fa42fe787e5e11c6ae2fa7a7970f76dd42c08d4 (patch)
treee09baa50daecf2f306d265f9f2c18444e698304f /utils/mariadb/patches
parent76441fe18ddd00d1f9b4cb16cc60444bbb3047bd (diff)
mariadb: fix compilation when selinux is present
Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'utils/mariadb/patches')
-rw-r--r--utils/mariadb/patches/200-no-selinux.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/utils/mariadb/patches/200-no-selinux.patch b/utils/mariadb/patches/200-no-selinux.patch
new file mode 100644
index 000000000..d7ed569f7
--- /dev/null
+++ b/utils/mariadb/patches/200-no-selinux.patch
@@ -0,0 +1,11 @@
+--- a/support-files/CMakeLists.txt
++++ b/support-files/CMakeLists.txt
+@@ -61,7 +61,7 @@ IF(UNIX)
+ INSTALL(FILES magic DESTINATION ${inst_location} COMPONENT SupportFiles)
+ INSTALL(DIRECTORY policy DESTINATION ${inst_location} COMPONENT SupportFiles)
+ FIND_PROGRAM(CHECKMODULE checkmodule)
+- FIND_PROGRAM(SEMODULE_PACKAGE semodule_package)
++# FIND_PROGRAM(SEMODULE_PACKAGE semodule_package)
+ MARK_AS_ADVANCED(CHECKMODULE SEMODULE_PACKAGE)
+
+ # Build pp files in policy/selinux