aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-10-11 21:50:32 -0700
committerRosen Penev <rosenp@gmail.com>2020-10-11 22:14:02 -0700
commit8fa42fe787e5e11c6ae2fa7a7970f76dd42c08d4 (patch)
treee09baa50daecf2f306d265f9f2c18444e698304f
parent76441fe18ddd00d1f9b4cb16cc60444bbb3047bd (diff)
mariadb: fix compilation when selinux is present
Signed-off-by: Rosen Penev <rosenp@gmail.com>
-rw-r--r--utils/mariadb/Makefile2
-rw-r--r--utils/mariadb/patches/200-no-selinux.patch11
2 files changed, 12 insertions, 1 deletions
diff --git a/utils/mariadb/Makefile b/utils/mariadb/Makefile
index 96b01fe2f..321ee70a9 100644
--- a/utils/mariadb/Makefile
+++ b/utils/mariadb/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=mariadb
PKG_VERSION:=10.4.14
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL := \
diff --git a/utils/mariadb/patches/200-no-selinux.patch b/utils/mariadb/patches/200-no-selinux.patch
new file mode 100644
index 000000000..d7ed569f7
--- /dev/null
+++ b/utils/mariadb/patches/200-no-selinux.patch
@@ -0,0 +1,11 @@
+--- a/support-files/CMakeLists.txt
++++ b/support-files/CMakeLists.txt
+@@ -61,7 +61,7 @@ IF(UNIX)
+ INSTALL(FILES magic DESTINATION ${inst_location} COMPONENT SupportFiles)
+ INSTALL(DIRECTORY policy DESTINATION ${inst_location} COMPONENT SupportFiles)
+ FIND_PROGRAM(CHECKMODULE checkmodule)
+- FIND_PROGRAM(SEMODULE_PACKAGE semodule_package)
++# FIND_PROGRAM(SEMODULE_PACKAGE semodule_package)
+ MARK_AS_ADVANCED(CHECKMODULE SEMODULE_PACKAGE)
+
+ # Build pp files in policy/selinux