aboutsummaryrefslogtreecommitdiff
path: root/utils/logrotate
diff options
context:
space:
mode:
authorHirokazu MORIKAWA <morikw2@gmail.com>2016-09-13 17:31:54 +0900
committerHirokazu MORIKAWA <morikw2@gmail.com>2016-09-13 17:31:54 +0900
commit0bf83dfc56c300dc6eb2ac5709cc5459f001102c (patch)
tree3c872f8fe9a8b467f5a0b2dd1e4a988ad63c72d0 /utils/logrotate
parent72f770f16b484b80b57935cd7c0833301678def4 (diff)
Fix nonnull-compare compile error
--- config.c: In function 'strndup': config.c:87:10: error: nonnull argument 's' compared to NULL [-Werror=nonnull-compare] if(!s) ^ cc1: all warnings being treated as errors --- Signed-off-by: Hirokazu MORIKAWA <morikw2@gmail.com>
Diffstat (limited to 'utils/logrotate')
-rw-r--r--utils/logrotate/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/utils/logrotate/Makefile b/utils/logrotate/Makefile
index dbfa92907..9218a8c76 100644
--- a/utils/logrotate/Makefile
+++ b/utils/logrotate/Makefile
@@ -38,7 +38,7 @@ define Package/logrotate/conffiles
/etc/logrotate.conf
endef
-EXTRA_CFLAGS += $(TARGET_CPPFLAGS)
+EXTRA_CFLAGS += $(TARGET_CPPFLAGS) -Wno-nonnull-compare
EXTRA_LDFLAGS += $(TARGET_LDFLAGS)
define Build/Compile