aboutsummaryrefslogtreecommitdiff
path: root/utils/logrotate
diff options
context:
space:
mode:
authorHannu Nyman <hannu.nyman@iki.fi>2016-09-12 20:23:06 +0300
committerGitHub <noreply@github.com>2016-09-12 20:23:06 +0300
commit72f770f16b484b80b57935cd7c0833301678def4 (patch)
tree6d20ebf6e463608758d0ba4d8128b8fd7dca2bbc /utils/logrotate
parent6c658bdbac040c1aeaa75dfa19ffadafee159889 (diff)
parent13c724173c8372584a3be7e3f4a52f0f317b5ec2 (diff)
Merge pull request #3144 from bk138/logrotate
logrotate: import from oldpackages
Diffstat (limited to 'utils/logrotate')
-rw-r--r--utils/logrotate/Makefile60
-rw-r--r--utils/logrotate/files/logrotate.conf30
2 files changed, 90 insertions, 0 deletions
diff --git a/utils/logrotate/Makefile b/utils/logrotate/Makefile
new file mode 100644
index 000000000..dbfa92907
--- /dev/null
+++ b/utils/logrotate/Makefile
@@ -0,0 +1,60 @@
+#
+# Copyright (C) 2006-2016 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=logrotate
+PKG_VERSION:=3.10.0
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:= https://github.com/logrotate/logrotate/releases/download/$(PKG_VERSION)
+PKG_MD5SUM:=888f58caf07082c76f5dd39e5d30ec12
+PKG_LICENSE:=GPL-2.0
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/logrotate
+ SECTION:=utils
+ CATEGORY:=Utilities
+ DEPENDS:=+libpopt
+ TITLE:=rotates, compresses, and mails system logs
+ URL:=https://github.com/logrotate/logrotate
+ MAINTAINER:=Christian Beier <cb@shoutrlabs.com>
+endef
+
+define Package/logrotate/description
+ logrotate is designed to ease administration of systems that generate large
+ numbers of log files. It allows auto-matic rotation, compression, removal and
+ mailing of log files. Each log file may be handled daily, weekly, monthly or
+ when it grows too large.
+endef
+
+define Package/logrotate/conffiles
+/etc/logrotate.conf
+endef
+
+EXTRA_CFLAGS += $(TARGET_CPPFLAGS)
+EXTRA_LDFLAGS += $(TARGET_LDFLAGS)
+
+define Build/Compile
+ $(call Build/Compile/Default, \
+ RPM_OPT_FLAGS:="$(TARGET_CFLAGS) $(EXTRA_CFLAGS)" \
+ LDFLAGS="$(EXTRA_LDFLAGS)" \
+ logrotate \
+ )
+endef
+
+define Package/logrotate/install
+ $(INSTALL_DIR) $(1)/usr/sbin
+ $(INSTALL_BIN) ${PKG_BUILD_DIR}/logrotate $(1)/usr/sbin/
+ $(INSTALL_DIR) $(1)/etc
+ $(INSTALL_DATA) ./files/logrotate.conf $(1)/etc/
+ $(INSTALL_DIR) $(1)/etc/logrotate.d
+endef
+
+$(eval $(call BuildPackage,logrotate))
diff --git a/utils/logrotate/files/logrotate.conf b/utils/logrotate/files/logrotate.conf
new file mode 100644
index 000000000..9a91db94f
--- /dev/null
+++ b/utils/logrotate/files/logrotate.conf
@@ -0,0 +1,30 @@
+# rotate log files weekly
+weekly
+#daily
+
+# keep 4 weeks worth of backlogs
+rotate 4
+
+# create new (empty) log files after rotating old ones
+create
+
+notifempty
+nomail
+#olddir /var/log/backup/
+missingok
+#dateext
+
+# uncomment this if you want your log files compressed
+#compress
+
+# packages can drop log rotation information into this directory
+include /etc/logrotate.d
+
+# no packages own lastlog or wtmp -- we'll rotate them here
+#/var/log/wtmp {
+# monthly
+# create 0664 root utmp
+# rotate 1
+#}
+
+# system-specific logs may be also be configured here.