aboutsummaryrefslogtreecommitdiff
path: root/utils/dbus/Makefile
diff options
context:
space:
mode:
authorFlorian Eckert <fe@dev.tdt.de>2021-12-10 13:50:46 +0100
committerFlorian Eckert <fe@dev.tdt.de>2021-12-10 15:08:51 +0100
commit9fa04c296f97670f45a626ebc6a053f38a01bd3c (patch)
tree12ec4ae22f93a300939f86d6b6c0a06b61c54a6f /utils/dbus/Makefile
parent7fb856d9b85db79c1a7cca7f7df108f5d4a9522d (diff)
dbus: add debug compile option
To simplify the debugging of dbus problems, the VERBOSE option for the dbus can now be switched on via make menuconfig. This is switched off by default. If this is switched on, the dbus package must be recompiled. Signed-off-by: Florian Eckert <fe@dev.tdt.de>
Diffstat (limited to 'utils/dbus/Makefile')
-rw-r--r--utils/dbus/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/utils/dbus/Makefile b/utils/dbus/Makefile
index d52b25e79..9927f0b59 100644
--- a/utils/dbus/Makefile
+++ b/utils/dbus/Makefile
@@ -19,6 +19,9 @@ PKG_MAINTAINER:=
PKG_LICENSE:=AFL-2.1
PKG_CPE_ID:=cpe:/a:freedesktop:dbus
+PKG_CONFIG_DEPENDS:= \
+ CONFIG_DBUS_VERBOSE
+
include $(INCLUDE_DIR)/package.mk
include $(INCLUDE_DIR)/cmake.mk
@@ -71,6 +74,10 @@ $(call Package/dbus/Default/description)
This package contains D-Bus utilities.
endef
+define Package/dbus/config
+ source "$(SOURCE)/Config.in"
+endef
+
CMAKE_OPTIONS += \
-DDBUS_SYSTEM_SOCKET=/var/run/dbus/system_bus_socket \
-DDBUS_SESSION_SOCKET_DIR=/tmp \
@@ -90,6 +97,10 @@ CMAKE_OPTIONS += \
-DDBUS_ENABLE_QTHELP_DOCS=OFF \
-DDBUS_ENABLE_XML_DOCS=OFF
+ifeq ($(CONFIG_DBUS_VERBOSE),y)
+ CMAKE_OPTIONS += -DDBUS_ENABLE_VERBOSE_MODE=ON
+endif
+
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/include
$(CP) $(PKG_INSTALL_DIR)/usr/include/dbus-1.0 $(1)/usr/include/