aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--utils/dbus/Config.in7
-rw-r--r--utils/dbus/Makefile11
2 files changed, 18 insertions, 0 deletions
diff --git a/utils/dbus/Config.in b/utils/dbus/Config.in
new file mode 100644
index 000000000..86ceed5f6
--- /dev/null
+++ b/utils/dbus/Config.in
@@ -0,0 +1,7 @@
+if PACKAGE_dbus
+
+config DBUS_VERBOSE
+ bool "Enable verbose error strings"
+ default n
+
+endif
diff --git a/utils/dbus/Makefile b/utils/dbus/Makefile
index d52b25e79..9927f0b59 100644
--- a/utils/dbus/Makefile
+++ b/utils/dbus/Makefile
@@ -19,6 +19,9 @@ PKG_MAINTAINER:=
PKG_LICENSE:=AFL-2.1
PKG_CPE_ID:=cpe:/a:freedesktop:dbus
+PKG_CONFIG_DEPENDS:= \
+ CONFIG_DBUS_VERBOSE
+
include $(INCLUDE_DIR)/package.mk
include $(INCLUDE_DIR)/cmake.mk
@@ -71,6 +74,10 @@ $(call Package/dbus/Default/description)
This package contains D-Bus utilities.
endef
+define Package/dbus/config
+ source "$(SOURCE)/Config.in"
+endef
+
CMAKE_OPTIONS += \
-DDBUS_SYSTEM_SOCKET=/var/run/dbus/system_bus_socket \
-DDBUS_SESSION_SOCKET_DIR=/tmp \
@@ -90,6 +97,10 @@ CMAKE_OPTIONS += \
-DDBUS_ENABLE_QTHELP_DOCS=OFF \
-DDBUS_ENABLE_XML_DOCS=OFF
+ifeq ($(CONFIG_DBUS_VERBOSE),y)
+ CMAKE_OPTIONS += -DDBUS_ENABLE_VERBOSE_MODE=ON
+endif
+
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/include
$(CP) $(PKG_INSTALL_DIR)/usr/include/dbus-1.0 $(1)/usr/include/