aboutsummaryrefslogtreecommitdiff
path: root/utils/acpid
diff options
context:
space:
mode:
authorRob Mosher <nyt-openwrt@countercultured.net>2020-05-27 06:48:34 -0400
committerRob Mosher <nyt-github@countercultured.net>2020-05-27 06:48:34 -0400
commitbf668c35b755c8df5b2393c37db85eafbc3ba62f (patch)
treeffc958aa94f9576bcaf7a8711881c5ee10d08d4e /utils/acpid
parent26291bba4eb4bd4ddea16b702d326d75845c3b42 (diff)
acpid: fix init script
init script would error: procd: /etc/rc.d/S99acpid: /etc/rc.common: /etc/rc.d/S99acpid: line 18: procd_send_signal: not found procd: /etc/rc.d/S99acpid: /etc/rc.common: /etc/rc.d/S99acpid: line 19: syntax error: unexpected "}" Signed-off-by: Rob Mosher <nyt-openwrt@countercultured.net>
Diffstat (limited to 'utils/acpid')
-rw-r--r--utils/acpid/Makefile2
-rw-r--r--utils/acpid/files/acpid.init4
2 files changed, 3 insertions, 3 deletions
diff --git a/utils/acpid/Makefile b/utils/acpid/Makefile
index 5217c2962..9328cbd7e 100644
--- a/utils/acpid/Makefile
+++ b/utils/acpid/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=acpid
PKG_VERSION:=2.0.32
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=@SF/acpid2
diff --git a/utils/acpid/files/acpid.init b/utils/acpid/files/acpid.init
index c860327ca..411eea255 100644
--- a/utils/acpid/files/acpid.init
+++ b/utils/acpid/files/acpid.init
@@ -1,4 +1,4 @@
-#!/bin/ash /etc/rc.common
+#!/bin/sh /etc/rc.common
# Copyright (C) 2009-2010 OpenWrt.org
START=99
@@ -14,6 +14,6 @@ start_service() {
procd_set_param pidfile "/var/run/acpid.pid"
}
-reload_service()\ {
+reload_service() {
procd_send_signal "acpid"
}