aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorHannu Nyman <hannu.nyman@iki.fi>2018-12-06 10:33:49 +0200
committerGitHub <noreply@github.com>2018-12-06 10:33:49 +0200
commite0361826928c343aa65f8e697916c825a98e39f3 (patch)
treea1bebdacbd8d448a18ba9b5b9d017026df9f2147 /net
parent78a364e48c31756e3c74d628ca6b4b9b363b86ce (diff)
parent9ef3498e9181864a0e07a7514eb6655fdff55cb9 (diff)
Merge pull request #7585 from dengqf6/nginx
nginx: fix detection of gcc builtin atomic operations
Diffstat (limited to 'net')
-rw-r--r--net/nginx/Makefile2
-rw-r--r--net/nginx/patches/101-feature_test_fix.patch9
2 files changed, 10 insertions, 1 deletions
diff --git a/net/nginx/Makefile b/net/nginx/Makefile
index 671caa67d..bb016d031 100644
--- a/net/nginx/Makefile
+++ b/net/nginx/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=nginx
PKG_VERSION:=1.15.6
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=nginx-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://nginx.org/download/
diff --git a/net/nginx/patches/101-feature_test_fix.patch b/net/nginx/patches/101-feature_test_fix.patch
index 930e7da98..b867c88dd 100644
--- a/net/nginx/patches/101-feature_test_fix.patch
+++ b/net/nginx/patches/101-feature_test_fix.patch
@@ -11,6 +11,15 @@
ngx_feature_libs=
--- a/auto/cc/conf
+++ b/auto/cc/conf
+@@ -183,7 +183,7 @@ if [ "$NGX_PLATFORM" != win32 ]; then
+ else
+ ngx_feature="gcc builtin atomic operations"
+ ngx_feature_name=NGX_HAVE_GCC_ATOMIC
+- ngx_feature_run=yes
++ ngx_feature_run=no
+ ngx_feature_incs=
+ ngx_feature_path=
+ ngx_feature_libs=
@@ -204,7 +204,7 @@ if [ "$NGX_PLATFORM" != win32 ]; then
else
ngx_feature="C99 variadic macros"