aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorHannu Nyman <hannu.nyman@iki.fi>2018-12-06 10:32:41 +0200
committerGitHub <noreply@github.com>2018-12-06 10:32:41 +0200
commit78a364e48c31756e3c74d628ca6b4b9b363b86ce (patch)
tree609108bcb9c89b30316a6567aac33054dde36eae /net
parent18a10cec4804f862409656b7f674b4d50ec149e1 (diff)
parent8d04517d6087e8591bcbc332bee1e636b10cf819 (diff)
Merge pull request #7569 from dengqf6/aria2
aria2: code size optimizations and build-parallel
Diffstat (limited to 'net')
-rw-r--r--net/aria2/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/net/aria2/Makefile b/net/aria2/Makefile
index 940855697..68dfc3010 100644
--- a/net/aria2/Makefile
+++ b/net/aria2/Makefile
@@ -14,6 +14,7 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=https://github.com/aria2/aria2/releases/download/release-$(PKG_VERSION)/
PKG_HASH:=3a44a802631606e138a9e172a3e9f5bcbaac43ce2895c1d8e2b46f30487e77a3
PKG_INSTALL:=1
+PKG_BUILD_PARALLEL:=1
PKG_MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>, \
Hsing-Wang Liao <kuoruan@gmail.com>
@@ -80,6 +81,9 @@ CONFIGURE_ARGS += \
--without-libuv \
--with-libz
+TARGET_CXXFLAGS += -ffunction-sections -fdata-sections -flto
+TARGET_LDFLAGS += -Wl,--gc-sections -flto
+
define Package/aria2/install
$(INSTALL_DIR) $(1)/usr/bin
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/aria2c $(1)/usr/bin