aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2019-07-20 09:58:38 -0700
committerGitHub <noreply@github.com>2019-07-20 09:58:38 -0700
commitb1a3042b9ea01c31ab016b4d64de768d43dfad36 (patch)
tree4c8fffa8005a81943c8d799502e4cec983131f53 /net
parent621dd1f866421046b12368d44e1540ac5a39abd2 (diff)
parentc1a9e69feff5c879ddcdf476f59285b137c05ecd (diff)
Merge pull request #9519 from neheb/libre
libreswan: Replace usleep with nanosleep
Diffstat (limited to 'net')
-rw-r--r--net/libreswan/Makefile4
-rw-r--r--net/libreswan/patches/010-nanosleep.patch21
2 files changed, 24 insertions, 1 deletions
diff --git a/net/libreswan/Makefile b/net/libreswan/Makefile
index 5b71685e1..ccd1a4f22 100644
--- a/net/libreswan/Makefile
+++ b/net/libreswan/Makefile
@@ -14,8 +14,10 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://download.libreswan.org/
PKG_HASH:=d60e4160f43272b6307b697a13f79f56b5ec2bca61d83097ddadd8586a58ab3e
-PKG_LICENSE:=GPL-2.0
PKG_MAINTAINER:=Lucian Cristian <lucian.cristian@gmail.com>
+PKG_LICENSE:=GPL-2.0-or-later
+PKG_LICENSE_FILES:=COPYING LICENSE
+PKG_CPE_ID:=cpe:/a:libreswan:libreswan
PKG_BUILD_PARALLEL:=1
PKG_INSTALL:=1
diff --git a/net/libreswan/patches/010-nanosleep.patch b/net/libreswan/patches/010-nanosleep.patch
new file mode 100644
index 000000000..a7fd829fd
--- /dev/null
+++ b/net/libreswan/patches/010-nanosleep.patch
@@ -0,0 +1,21 @@
+--- a/programs/pluto/send.c
++++ b/programs/pluto/send.c
+@@ -26,7 +26,7 @@
+ *
+ */
+
+-#include <unistd.h> /* for usleep() */
++#include <time.h> /* for nanosleep() */
+ #include <errno.h>
+
+ #include "defs.h"
+@@ -173,7 +173,8 @@ bool send_chunks(const char *where, bool just_a_keepalive,
+ /* Send a duplicate packet when this impair is enabled - used for testing */
+ if (IMPAIR(JACOB_TWO_TWO)) {
+ /* sleep for half a second, and second another packet */
+- usleep(500000);
++ const struct timespec req = {0, 500 * 1000 * 1000};
++ nanosleep(&req, NULL);
+ ip_endpoint_buf b;
+
+ DBG_log("JACOB 2-2: resending %zu bytes for %s through %s:%d to %s:",