aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2019-07-19 00:41:11 -0700
committerRosen Penev <rosenp@gmail.com>2019-07-19 00:42:32 -0700
commitc1a9e69feff5c879ddcdf476f59285b137c05ecd (patch)
treed6555db3779557535cc8c73767b7654d719a083a /net
parentc8734591ca2d2c9e69a69591ccd1365795826689 (diff)
libreswan: Replace usleep with nanosleep
usleep is optionally unavailable with uClibc-ng. Added PKG_LICENSE_FILES Added PKG_CPE_ID for proper CVE tracking. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'net')
-rw-r--r--net/libreswan/Makefile4
-rw-r--r--net/libreswan/patches/010-nanosleep.patch21
2 files changed, 24 insertions, 1 deletions
diff --git a/net/libreswan/Makefile b/net/libreswan/Makefile
index 5b71685e1..ccd1a4f22 100644
--- a/net/libreswan/Makefile
+++ b/net/libreswan/Makefile
@@ -14,8 +14,10 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://download.libreswan.org/
PKG_HASH:=d60e4160f43272b6307b697a13f79f56b5ec2bca61d83097ddadd8586a58ab3e
-PKG_LICENSE:=GPL-2.0
PKG_MAINTAINER:=Lucian Cristian <lucian.cristian@gmail.com>
+PKG_LICENSE:=GPL-2.0-or-later
+PKG_LICENSE_FILES:=COPYING LICENSE
+PKG_CPE_ID:=cpe:/a:libreswan:libreswan
PKG_BUILD_PARALLEL:=1
PKG_INSTALL:=1
diff --git a/net/libreswan/patches/010-nanosleep.patch b/net/libreswan/patches/010-nanosleep.patch
new file mode 100644
index 000000000..a7fd829fd
--- /dev/null
+++ b/net/libreswan/patches/010-nanosleep.patch
@@ -0,0 +1,21 @@
+--- a/programs/pluto/send.c
++++ b/programs/pluto/send.c
+@@ -26,7 +26,7 @@
+ *
+ */
+
+-#include <unistd.h> /* for usleep() */
++#include <time.h> /* for nanosleep() */
+ #include <errno.h>
+
+ #include "defs.h"
+@@ -173,7 +173,8 @@ bool send_chunks(const char *where, bool just_a_keepalive,
+ /* Send a duplicate packet when this impair is enabled - used for testing */
+ if (IMPAIR(JACOB_TWO_TWO)) {
+ /* sleep for half a second, and second another packet */
+- usleep(500000);
++ const struct timespec req = {0, 500 * 1000 * 1000};
++ nanosleep(&req, NULL);
+ ip_endpoint_buf b;
+
+ DBG_log("JACOB 2-2: resending %zu bytes for %s through %s:%d to %s:",