aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorHannu Nyman <hannu.nyman@iki.fi>2019-10-12 14:46:06 +0300
committerGitHub <noreply@github.com>2019-10-12 14:46:06 +0300
commit7de37d7fea41a285c57a9593612548cd8b509ec0 (patch)
tree6d2202adaf0ca99523b7486894a7bda74c22776e /net
parentfd85ad09097a05276dcd8bc8518ec96460c8161e (diff)
parentb9c7a570a2342c65ad049e4e77e038b3f8f3b90a (diff)
Merge pull request #10193 from Ansuel/nginx-sock
nginx: adds new socket to luci uwsgi config
Diffstat (limited to 'net')
-rw-r--r--net/nginx/Makefile4
-rw-r--r--net/nginx/files-luci-support/luci_uwsgi.conf26
2 files changed, 14 insertions, 16 deletions
diff --git a/net/nginx/Makefile b/net/nginx/Makefile
index 244b7abe0..c14fb1579 100644
--- a/net/nginx/Makefile
+++ b/net/nginx/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=nginx
PKG_VERSION:=1.16.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=nginx-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://nginx.org/download/
@@ -196,6 +196,8 @@ ifneq ($(BUILD_VARIANT),all-module)
endif
ifneq ($(CONFIG_NGINX_HTTP_UWSGI),y)
ADDITIONAL_MODULES += --without-http_uwsgi_module
+ else
+ config_files += uwsgi_params
endif
ifneq ($(CONFIG_NGINX_HTTP_SCGI),y)
ADDITIONAL_MODULES += --without-http_scgi_module
diff --git a/net/nginx/files-luci-support/luci_uwsgi.conf b/net/nginx/files-luci-support/luci_uwsgi.conf
index 6211db74a..404eff2a6 100644
--- a/net/nginx/files-luci-support/luci_uwsgi.conf
+++ b/net/nginx/files-luci-support/luci_uwsgi.conf
@@ -1,19 +1,15 @@
location /cgi-bin/luci {
- index index.html;
- uwsgi_param QUERY_STRING $query_string;
- uwsgi_param REQUEST_METHOD $request_method;
- uwsgi_param CONTENT_TYPE $content_type;
- uwsgi_param CONTENT_LENGTH $content_length if_not_empty;
- uwsgi_param REQUEST_URI $request_uri;
- uwsgi_param PATH_INFO $document_uri;
- uwsgi_param SERVER_PROTOCOL $server_protocol;
- uwsgi_param REMOTE_ADDR $remote_addr;
- uwsgi_param REMOTE_PORT $remote_port;
- uwsgi_param SERVER_ADDR $server_addr;
- uwsgi_param SERVER_PORT $server_port;
- uwsgi_param SERVER_NAME $server_name;
- uwsgi_modifier1 9;
- uwsgi_pass unix:////var/run/uwsgi.sock;
+ index index.html;
+ include uwsgi_params;
+ uwsgi_param SERVER_ADDR $server_addr;
+ uwsgi_modifier1 9;
+ uwsgi_pass unix:////var/run/luci-webui.socket;
+}
+location ~ /cgi-bin/cgi-(backup|download|upload) {
+ include uwsgi_params;
+ uwsgi_param SERVER_ADDR $server_addr;
+ uwsgi_modifier1 9;
+ uwsgi_pass unix:////var/run/luci-cgi_io.socket;
}
location /luci-static {