aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorAnsuel Smith <ansuelsmth@gmail.com>2019-10-09 20:30:14 +0200
committerAnsuel Smith <ansuelsmth@gmail.com>2019-10-12 13:22:08 +0200
commitb9c7a570a2342c65ad049e4e77e038b3f8f3b90a (patch)
tree470adb7140fcddf472d11c4fbc2c20ad8b458a1b /net
parent7a5326dd29fabf2d405603e24159323b4f792759 (diff)
nginx: adds new socket to luci uwsgi config
Signed-off-by: Ansuel Smith <ansuelsmth@gmail.com>
Diffstat (limited to 'net')
-rw-r--r--net/nginx/Makefile4
-rw-r--r--net/nginx/files-luci-support/luci_uwsgi.conf26
2 files changed, 14 insertions, 16 deletions
diff --git a/net/nginx/Makefile b/net/nginx/Makefile
index 244b7abe0..c14fb1579 100644
--- a/net/nginx/Makefile
+++ b/net/nginx/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=nginx
PKG_VERSION:=1.16.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=nginx-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://nginx.org/download/
@@ -196,6 +196,8 @@ ifneq ($(BUILD_VARIANT),all-module)
endif
ifneq ($(CONFIG_NGINX_HTTP_UWSGI),y)
ADDITIONAL_MODULES += --without-http_uwsgi_module
+ else
+ config_files += uwsgi_params
endif
ifneq ($(CONFIG_NGINX_HTTP_SCGI),y)
ADDITIONAL_MODULES += --without-http_scgi_module
diff --git a/net/nginx/files-luci-support/luci_uwsgi.conf b/net/nginx/files-luci-support/luci_uwsgi.conf
index 6211db74a..404eff2a6 100644
--- a/net/nginx/files-luci-support/luci_uwsgi.conf
+++ b/net/nginx/files-luci-support/luci_uwsgi.conf
@@ -1,19 +1,15 @@
location /cgi-bin/luci {
- index index.html;
- uwsgi_param QUERY_STRING $query_string;
- uwsgi_param REQUEST_METHOD $request_method;
- uwsgi_param CONTENT_TYPE $content_type;
- uwsgi_param CONTENT_LENGTH $content_length if_not_empty;
- uwsgi_param REQUEST_URI $request_uri;
- uwsgi_param PATH_INFO $document_uri;
- uwsgi_param SERVER_PROTOCOL $server_protocol;
- uwsgi_param REMOTE_ADDR $remote_addr;
- uwsgi_param REMOTE_PORT $remote_port;
- uwsgi_param SERVER_ADDR $server_addr;
- uwsgi_param SERVER_PORT $server_port;
- uwsgi_param SERVER_NAME $server_name;
- uwsgi_modifier1 9;
- uwsgi_pass unix:////var/run/uwsgi.sock;
+ index index.html;
+ include uwsgi_params;
+ uwsgi_param SERVER_ADDR $server_addr;
+ uwsgi_modifier1 9;
+ uwsgi_pass unix:////var/run/luci-webui.socket;
+}
+location ~ /cgi-bin/cgi-(backup|download|upload) {
+ include uwsgi_params;
+ uwsgi_param SERVER_ADDR $server_addr;
+ uwsgi_modifier1 9;
+ uwsgi_pass unix:////var/run/luci-cgi_io.socket;
}
location /luci-static {