aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorErik Conijn <egc112@msn.com>2024-01-17 13:31:37 +0100
committerRosen Penev <rosenp@gmail.com>2024-01-29 16:06:13 -0800
commit61eb0a3d965a3a3e8eed24c9689e67c82a991203 (patch)
tree1f2197336c8a7dd1852d7de8e8a2628ebe19d294 /net
parentc813aaaed73f3e093c469e40340ecd48729dc3f5 (diff)
openvpn: add missing script-security
Maintainer: @mkrkn @neheb Compile tested: armv7, cortexA15, OpenWRT 23.05 Run tested: Linksys EA8500 Compile tested: armv8, cortexA53, OpenWRT main Run tested: Dynalink DL-WRX36 Description: Script-security is always 2 and cannot be changed from the openvpn config file due to a missing rule in openvpn.init. This is discussed in issue #23014 This patch adds the missing rule in openvpn.init to parse script-security from the openvpn config file. Signed-off-by: Erik Conijn <egc112@msn.com>
Diffstat (limited to 'net')
-rw-r--r--net/openvpn/Makefile2
-rw-r--r--net/openvpn/files/openvpn.init1
2 files changed, 2 insertions, 1 deletions
diff --git a/net/openvpn/Makefile b/net/openvpn/Makefile
index af3b7a8be..e85b6e75b 100644
--- a/net/openvpn/Makefile
+++ b/net/openvpn/Makefile
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=openvpn
PKG_VERSION:=2.6.8
-PKG_RELEASE:=3
+PKG_RELEASE:=4
PKG_SOURCE_URL:=\
https://build.openvpn.net/downloads/releases/ \
diff --git a/net/openvpn/files/openvpn.init b/net/openvpn/files/openvpn.init
index 0aee6d418..89d25b59c 100644
--- a/net/openvpn/files/openvpn.init
+++ b/net/openvpn/files/openvpn.init
@@ -201,6 +201,7 @@ start_uci_instance() {
if [ ! -z "$config" ]; then
append UCI_STARTED "$config" "$LIST_SEP"
+ [ -n "$script_security" ] || get_openvpn_option "$config" script_security script-security
[ -n "$up" ] || get_openvpn_option "$config" up up
[ -n "$down" ] || get_openvpn_option "$config" down down
[ -n "$route_up" ] || get_openvpn_option "$config" route_up route-up