aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net/openvpn/Makefile2
-rw-r--r--net/openvpn/files/openvpn.init1
2 files changed, 2 insertions, 1 deletions
diff --git a/net/openvpn/Makefile b/net/openvpn/Makefile
index af3b7a8be..e85b6e75b 100644
--- a/net/openvpn/Makefile
+++ b/net/openvpn/Makefile
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=openvpn
PKG_VERSION:=2.6.8
-PKG_RELEASE:=3
+PKG_RELEASE:=4
PKG_SOURCE_URL:=\
https://build.openvpn.net/downloads/releases/ \
diff --git a/net/openvpn/files/openvpn.init b/net/openvpn/files/openvpn.init
index 0aee6d418..89d25b59c 100644
--- a/net/openvpn/files/openvpn.init
+++ b/net/openvpn/files/openvpn.init
@@ -201,6 +201,7 @@ start_uci_instance() {
if [ ! -z "$config" ]; then
append UCI_STARTED "$config" "$LIST_SEP"
+ [ -n "$script_security" ] || get_openvpn_option "$config" script_security script-security
[ -n "$up" ] || get_openvpn_option "$config" up up
[ -n "$down" ] || get_openvpn_option "$config" down down
[ -n "$route_up" ] || get_openvpn_option "$config" route_up route-up