aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorPetr Štetiar <ynezz@true.cz>2019-10-11 15:03:04 +0200
committerJohn Crispin <john@phrozen.org>2019-10-11 16:03:54 +0200
commit4e7411a8d0a46363f9946bff762eda70d5d5de6c (patch)
treee06314edd45552d85554fa5f1bfdb6fbe5216666 /net
parentfd47e99be4fcd9b1261a4f359279d63199fff6c3 (diff)
cgi-io: cmake: enable extra compiler warnings
Spotting issues during compilation is cheaper. Signed-off-by: Petr Štetiar <ynezz@true.cz>
Diffstat (limited to 'net')
-rw-r--r--net/cgi-io/src/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/net/cgi-io/src/CMakeLists.txt b/net/cgi-io/src/CMakeLists.txt
index 56d9fa7f1..c7c9d40ca 100644
--- a/net/cgi-io/src/CMakeLists.txt
+++ b/net/cgi-io/src/CMakeLists.txt
@@ -9,7 +9,8 @@ FIND_LIBRARY(ubox NAMES ubox)
FIND_LIBRARY(ubus NAMES ubus)
INCLUDE_DIRECTORIES(${ubus_include_dir})
-ADD_DEFINITIONS(-Os -Wall -Werror --std=gnu99 -g3 -Wmissing-declarations)
+ADD_DEFINITIONS(-Os -Wall -Werror -Wextra --std=gnu99 -g3)
+ADD_DEFINITIONS(-Wno-unused-parameter -Wmissing-declarations)
SET(CMAKE_SHARED_LIBRARY_LINK_C_FLAGS "")