aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorPetr Štetiar <ynezz@true.cz>2019-10-11 15:01:42 +0200
committerJohn Crispin <john@phrozen.org>2019-10-11 16:03:54 +0200
commitfd47e99be4fcd9b1261a4f359279d63199fff6c3 (patch)
treec5a09a24e4bdc7fb0eb95c76568a5970c559261b /net
parentf22bd6116a36610dcee110ad4380cf6ecd2fa1f6 (diff)
cgi-io: cmake: fix libraries lookup
In order to make it compile properly in more environments. Signed-off-by: Petr Štetiar <ynezz@true.cz>
Diffstat (limited to 'net')
-rw-r--r--net/cgi-io/src/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/net/cgi-io/src/CMakeLists.txt b/net/cgi-io/src/CMakeLists.txt
index 6d8b1585a..56d9fa7f1 100644
--- a/net/cgi-io/src/CMakeLists.txt
+++ b/net/cgi-io/src/CMakeLists.txt
@@ -5,6 +5,8 @@ PROJECT(cgi-io C)
INCLUDE(CheckFunctionExists)
FIND_PATH(ubus_include_dir libubus.h)
+FIND_LIBRARY(ubox NAMES ubox)
+FIND_LIBRARY(ubus NAMES ubus)
INCLUDE_DIRECTORIES(${ubus_include_dir})
ADD_DEFINITIONS(-Os -Wall -Werror --std=gnu99 -g3 -Wmissing-declarations)
@@ -17,6 +19,6 @@ IF(APPLE)
ENDIF()
ADD_EXECUTABLE(cgi-io main.c multipart_parser.c)
-TARGET_LINK_LIBRARIES(cgi-io ubox ubus)
+TARGET_LINK_LIBRARIES(cgi-io ${ubox} ${ubus})
INSTALL(TARGETS cgi-io RUNTIME DESTINATION sbin)