aboutsummaryrefslogtreecommitdiff
path: root/net/zerotier/Makefile
diff options
context:
space:
mode:
authorMoritz Warning <moritzwarning@web.de>2019-09-02 03:48:44 +0200
committerMoritz Warning <moritzwarning@web.de>2019-09-03 15:14:27 +0200
commit966e56fa8281adb0d94ea913c8354bc2af135c80 (patch)
treea8aafe49ede71a1f1065c4e2897511015bf3decc /net/zerotier/Makefile
parent642ac0b1ebb6dae3f02b6c6082d6ca3dd7f86f1d (diff)
zerotier: update to release 1.4.4
Also allow path to local.conf to be set and enable linker optimisations to save a few bytes. Signed-off-by: Moritz Warning <moritzwarning@web.de>
Diffstat (limited to 'net/zerotier/Makefile')
-rw-r--r--net/zerotier/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/net/zerotier/Makefile b/net/zerotier/Makefile
index 4a69d5e6b..1ccb21bfd 100644
--- a/net/zerotier/Makefile
+++ b/net/zerotier/Makefile
@@ -6,12 +6,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=zerotier
-PKG_VERSION:=1.4.2
+PKG_VERSION:=1.4.4
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/zerotier/ZeroTierOne/tar.gz/$(PKG_VERSION)?
-PKG_HASH:=557a444127812384265ec97232bae43dce1d4b1545ddd72e2b1646c971dad7c5
+PKG_HASH:=0c11aab77b1c30fb8932e31906fc93fe7cb38c579c33740c1d407ec13d5b3e12
PKG_BUILD_DIR:=$(BUILD_DIR)/ZeroTierOne-$(PKG_VERSION)
PKG_MAINTAINER:=Moritz Warning <moritzwarning@web.de>
@@ -54,7 +54,7 @@ endef
# Make binary smaller
TARGET_CFLAGS += -ffunction-sections -fdata-sections
-TARGET_LDFLAGS += -Wl,--gc-sections
+TARGET_LDFLAGS += -Wl,--gc-sections,--as-needed
ifdef CONFIG_USE_UCLIBC
TARGET_CFLAGS += -D'valloc(a)=aligned_alloc(getpagesize(),a)'