aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorMoritz Warning <moritzwarning@web.de>2019-09-02 03:48:44 +0200
committerMoritz Warning <moritzwarning@web.de>2019-09-03 15:14:27 +0200
commit966e56fa8281adb0d94ea913c8354bc2af135c80 (patch)
treea8aafe49ede71a1f1065c4e2897511015bf3decc /net
parent642ac0b1ebb6dae3f02b6c6082d6ca3dd7f86f1d (diff)
zerotier: update to release 1.4.4
Also allow path to local.conf to be set and enable linker optimisations to save a few bytes. Signed-off-by: Moritz Warning <moritzwarning@web.de>
Diffstat (limited to 'net')
-rw-r--r--net/zerotier/Makefile6
-rw-r--r--net/zerotier/files/etc/config/zerotier3
-rwxr-xr-xnet/zerotier/files/etc/init.d/zerotier7
3 files changed, 12 insertions, 4 deletions
diff --git a/net/zerotier/Makefile b/net/zerotier/Makefile
index 4a69d5e6b..1ccb21bfd 100644
--- a/net/zerotier/Makefile
+++ b/net/zerotier/Makefile
@@ -6,12 +6,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=zerotier
-PKG_VERSION:=1.4.2
+PKG_VERSION:=1.4.4
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/zerotier/ZeroTierOne/tar.gz/$(PKG_VERSION)?
-PKG_HASH:=557a444127812384265ec97232bae43dce1d4b1545ddd72e2b1646c971dad7c5
+PKG_HASH:=0c11aab77b1c30fb8932e31906fc93fe7cb38c579c33740c1d407ec13d5b3e12
PKG_BUILD_DIR:=$(BUILD_DIR)/ZeroTierOne-$(PKG_VERSION)
PKG_MAINTAINER:=Moritz Warning <moritzwarning@web.de>
@@ -54,7 +54,7 @@ endef
# Make binary smaller
TARGET_CFLAGS += -ffunction-sections -fdata-sections
-TARGET_LDFLAGS += -Wl,--gc-sections
+TARGET_LDFLAGS += -Wl,--gc-sections,--as-needed
ifdef CONFIG_USE_UCLIBC
TARGET_CFLAGS += -D'valloc(a)=aligned_alloc(getpagesize(),a)'
diff --git a/net/zerotier/files/etc/config/zerotier b/net/zerotier/files/etc/config/zerotier
index 1a016ebcf..f342f851b 100644
--- a/net/zerotier/files/etc/config/zerotier
+++ b/net/zerotier/files/etc/config/zerotier
@@ -7,6 +7,9 @@ config zerotier sample_config
#option port '9993'
+ # path to the local.conf
+ #option local_conf '/etc/zerotier.conf'
+
# Generate secret on first start
option secret ''
diff --git a/net/zerotier/files/etc/init.d/zerotier b/net/zerotier/files/etc/init.d/zerotier
index ba6b427fa..dacb47c09 100755
--- a/net/zerotier/files/etc/init.d/zerotier
+++ b/net/zerotier/files/etc/init.d/zerotier
@@ -14,7 +14,7 @@ section_enabled() {
start_instance() {
local cfg="$1"
- local port secret config_path path
+ local port secret config_path local_conf path
local args=""
if ! section_enabled "$cfg"; then
@@ -25,6 +25,7 @@ start_instance() {
config_get config_path $cfg 'config_path'
config_get port $cfg 'port'
config_get secret $cfg 'secret'
+ config_get local_conf $cfg 'local_conf'
path=${CONFIG_PATH}_$cfg
@@ -71,6 +72,10 @@ start_instance() {
rm -f $path/identity.public
fi
+ if [ -f "$local_conf" ]; then
+ ln -s "$local_conf" $path/local.conf
+ fi
+
add_join() {
# an (empty) config file will cause ZT to join a network
touch $path/networks.d/$1.conf