aboutsummaryrefslogtreecommitdiff
path: root/net/xl2tpd
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2015-06-05 17:11:07 +0200
committerDaniel Golle <daniel@makrotopia.org>2015-06-05 17:42:06 +0200
commite0b2a226a37845fdb8b789432174c788d62c6a64 (patch)
tree2d8dff07f252bbbe67a3e4790022f6cdfab46876 /net/xl2tpd
parent0f562aa7c3af47e5a32b648e82dc648fd69d585a (diff)
xl2tpd: fix xl2tpd options
The previous commit left an unwanted string in the options passed to xl2tpd-control. Remove that as well. Also set procd respawn parameter now that I'm at it. Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'net/xl2tpd')
-rw-r--r--net/xl2tpd/Makefile2
-rw-r--r--net/xl2tpd/files/l2tp.sh2
-rw-r--r--net/xl2tpd/files/xl2tpd.init1
3 files changed, 3 insertions, 2 deletions
diff --git a/net/xl2tpd/Makefile b/net/xl2tpd/Makefile
index cba7bf03f..13d510fb5 100644
--- a/net/xl2tpd/Makefile
+++ b/net/xl2tpd/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=xl2tpd
PKG_VERSION:=1.3.7pre20150524
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_MAINTAINER:=Daniel Golle <daniel@makrotopia.org>
PKG_LICENSE:=GPL-2.0
PKG_LICENSE_FILES:=LICENSE
diff --git a/net/xl2tpd/files/l2tp.sh b/net/xl2tpd/files/l2tp.sh
index d4a6505b9..afb3a51c1 100644
--- a/net/xl2tpd/files/l2tp.sh
+++ b/net/xl2tpd/files/l2tp.sh
@@ -86,7 +86,7 @@ proto_l2tp_setup() {
echo "${ipv6:++ipv6} ${pppd_options}" >> "${optfile}"
echo "${mtu:+mtu $mtu mru $mtu}" >> "${optfile}"
- xl2tpd-control add l2tp-${interface} pppoptfile=${optfile} lns=${server} timeout=20 || {
+ xl2tpd-control add l2tp-${interface} pppoptfile=${optfile} lns=${server} || {
echo "xl2tpd-control: Add l2tp-$interface failed" >&2
proto_setup_failed "$interface"
exit 1
diff --git a/net/xl2tpd/files/xl2tpd.init b/net/xl2tpd/files/xl2tpd.init
index 86098603e..7d2e9ea30 100644
--- a/net/xl2tpd/files/xl2tpd.init
+++ b/net/xl2tpd/files/xl2tpd.init
@@ -14,6 +14,7 @@ start_service() {
procd_open_instance
procd_set_param command $BIN -D -l -p "$PID_F"
+ procd_set_param respawn
procd_close_instance
}