aboutsummaryrefslogtreecommitdiff
path: root/net/socat
diff options
context:
space:
mode:
authorChukun Pan <amadeus@jmu.edu.cn>2021-09-28 11:30:02 +0800
committerRosen Penev <rosenp@gmail.com>2021-09-30 17:42:34 -0700
commit373053a1e488c3148856aa520fdbd86832eb7f77 (patch)
treeb57b9027f26894fd7ecf242d200178becf912985 /net/socat
parent94cdf89269a1d086d5f26cb80b6e8cd46e7a1979 (diff)
socat: update to 1.7.4.1
Remove upstreamed patch. Signed-off-by: Chukun Pan <amadeus@jmu.edu.cn>
Diffstat (limited to 'net/socat')
-rw-r--r--net/socat/Makefile6
-rw-r--r--net/socat/patches/100-usleep.patch18
2 files changed, 3 insertions, 21 deletions
diff --git a/net/socat/Makefile b/net/socat/Makefile
index 8b36f4dd7..b9b7ba881 100644
--- a/net/socat/Makefile
+++ b/net/socat/Makefile
@@ -6,12 +6,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=socat
-PKG_VERSION:=1.7.3.4
-PKG_RELEASE:=3
+PKG_VERSION:=1.7.4.1
+PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=http://www.dest-unreach.org/socat/download
-PKG_HASH:=972374ca86f65498e23e3259c2ee1b8f9dbeb04d12c2a78c0c9b5d1cb97dfdfc
+PKG_HASH:=3faca25614e89123dff5045680549ecef519d02e331aaf3c4f5a8f6837c675e9
PKG_MAINTAINER:=Ted Hess <thess@kitschensync.net>
PKG_LICENSE:=GPL-2.0-or-later OpenSSL
diff --git a/net/socat/patches/100-usleep.patch b/net/socat/patches/100-usleep.patch
deleted file mode 100644
index cead181c1..000000000
--- a/net/socat/patches/100-usleep.patch
+++ /dev/null
@@ -1,18 +0,0 @@
---- a/sycls.c
-+++ b/sycls.c
-@@ -1329,6 +1329,7 @@ unsigned int Sleep(unsigned int seconds)
- return retval;
- }
-
-+#if 0
- /* obsolete by POSIX.1-2001 */
- void Usleep(unsigned long usec) {
- Debug1("usleep(%lu)", usec);
-@@ -1336,6 +1337,7 @@ void Usleep(unsigned long usec) {
- Debug("usleep() ->");
- return;
- }
-+#endif
-
- #if HAVE_NANOSLEEP
- unsigned int Nanosleep(const struct timespec *req, struct timespec *rem) {