aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net/socat/Makefile6
-rw-r--r--net/socat/patches/100-usleep.patch18
2 files changed, 3 insertions, 21 deletions
diff --git a/net/socat/Makefile b/net/socat/Makefile
index 8b36f4dd7..b9b7ba881 100644
--- a/net/socat/Makefile
+++ b/net/socat/Makefile
@@ -6,12 +6,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=socat
-PKG_VERSION:=1.7.3.4
-PKG_RELEASE:=3
+PKG_VERSION:=1.7.4.1
+PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=http://www.dest-unreach.org/socat/download
-PKG_HASH:=972374ca86f65498e23e3259c2ee1b8f9dbeb04d12c2a78c0c9b5d1cb97dfdfc
+PKG_HASH:=3faca25614e89123dff5045680549ecef519d02e331aaf3c4f5a8f6837c675e9
PKG_MAINTAINER:=Ted Hess <thess@kitschensync.net>
PKG_LICENSE:=GPL-2.0-or-later OpenSSL
diff --git a/net/socat/patches/100-usleep.patch b/net/socat/patches/100-usleep.patch
deleted file mode 100644
index cead181c1..000000000
--- a/net/socat/patches/100-usleep.patch
+++ /dev/null
@@ -1,18 +0,0 @@
---- a/sycls.c
-+++ b/sycls.c
-@@ -1329,6 +1329,7 @@ unsigned int Sleep(unsigned int seconds)
- return retval;
- }
-
-+#if 0
- /* obsolete by POSIX.1-2001 */
- void Usleep(unsigned long usec) {
- Debug1("usleep(%lu)", usec);
-@@ -1336,6 +1337,7 @@ void Usleep(unsigned long usec) {
- Debug("usleep() ->");
- return;
- }
-+#endif
-
- #if HAVE_NANOSLEEP
- unsigned int Nanosleep(const struct timespec *req, struct timespec *rem) {