aboutsummaryrefslogtreecommitdiff
path: root/net/seafile-seahub
diff options
context:
space:
mode:
authorAlexandru Ardelean <ardeleanalex@gmail.com>2019-07-03 12:05:05 +0300
committerAlexandru Ardelean <ardeleanalex@gmail.com>2019-07-11 15:16:36 +0300
commit8c96971c08f8b6df09d214e88a34ea0dd1fccd66 (patch)
tree0e9c11aec3398398e866c7ad8be4b0f51e58f63c /net/seafile-seahub
parentb2394833650c58fbbac7df503373c349f470086c (diff)
django-webpack-loader: update packaging format + add python3 variant
This change also updates the maintainer email to cotequeiroz@gmail.com, as requested on a different change. Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
Diffstat (limited to 'net/seafile-seahub')
-rw-r--r--net/seafile-seahub/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/net/seafile-seahub/Makefile b/net/seafile-seahub/Makefile
index 41d36e164..ef8782a23 100644
--- a/net/seafile-seahub/Makefile
+++ b/net/seafile-seahub/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=seafile-seahub
PKG_VERSION:=6.3.4
-PKG_RELEASE:=6
+PKG_RELEASE:=7
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/haiwen/seahub/tar.gz/v$(PKG_VERSION)-server?
@@ -30,7 +30,7 @@ SEAFILE_PYTHON_DEPENDS:= \
simplejson chardet dateutil mysql pytz qrcode requests requests-oauthlib \
django django-constance django-appconf django-compressor django-formtools \
django-jsonfield django-picklefield django-postoffice django-restframework \
- pillow django-simple-captcha django-statici18n
+ pillow django-simple-captcha django-statici18n django-webpack-loader
define Package/seafile-seahub
SECTION:=net
@@ -38,7 +38,6 @@ define Package/seafile-seahub
TITLE:=Seafile server - seahub component
URL:=https://seafile.com/
DEPENDS:=+python \
- +django-webpack-loader \
+python-flup +gunicorn +openpyxl \
$(foreach dep,$(SEAFILE_PYTHON_DEPENDS),+python-$(dep))
endef