aboutsummaryrefslogtreecommitdiff
path: root/net/openvswitch/Makefile
diff options
context:
space:
mode:
authorStijn Tintel <stijn@linux-ipv6.be>2021-12-15 15:11:56 +0200
committerYousong Zhou <yszhou4tech@gmail.com>2021-12-16 13:27:24 +0800
commit6fe18ac4de8816ffbcdb97a705a067f2cfc5b1cf (patch)
treeb082d84ba828c528430e8f2265080942ce1e0136 /net/openvswitch/Makefile
parent5ffc45126d886f8d4767f9784f561e14a41bb493 (diff)
openvswitch: partially restore kmod-mpls dependency
Enabling OPENVSWITCH in the kernel config selects MPLS. This exposes the MPLS_ROUTING symbol, which is missing if kmod-mpls is not enabled. On kernel 5.4 this problem doesn't show up, as the Open vSwitch package uses the in-tree kernel modules rather than the upstream ones. Restore the kmod-mpls dependency when using the upstream kernel modules to fix build. Reported-by: Matthew Hagan <mnhagan88@gmail.com> Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
Diffstat (limited to 'net/openvswitch/Makefile')
-rw-r--r--net/openvswitch/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/net/openvswitch/Makefile b/net/openvswitch/Makefile
index abd202eda..2b846f625 100644
--- a/net/openvswitch/Makefile
+++ b/net/openvswitch/Makefile
@@ -17,7 +17,7 @@ include ./openvswitch.mk
#
PKG_NAME:=openvswitch
PKG_VERSION:=$(ovs_version)
-PKG_RELEASE:=10
+PKG_RELEASE:=11
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://www.openvswitch.org/releases/
PKG_HASH:=7d5797f2bf2449c6a266149e88f72123540f7fe7f31ad52902057ae8d8f88c38
@@ -76,6 +76,7 @@ ovs_kmod_openvswitch_title:=Open vSwitch kernel datapath (upstream)
ovs_kmod_openvswitch_kconfig:=CONFIG_OPENVSWITCH
ovs_kmod_openvswitch_depends:=\
+kmod-lib-crc32c \
+ +kmod-mpls \
+kmod-nf-nat \
+IPV6:kmod-nf-nat6 \
+kmod-nf-conntrack \