aboutsummaryrefslogtreecommitdiff
path: root/net/openvswitch/Makefile
diff options
context:
space:
mode:
authorMatthew Hagan <mathagan@fb.com>2021-12-15 15:42:09 +0000
committerYousong Zhou <yszhou4tech@gmail.com>2021-12-16 13:25:37 +0800
commit5ffc45126d886f8d4767f9784f561e14a41bb493 (patch)
tree14d138f225609d06b6f186be23d6905ced4964c3 /net/openvswitch/Makefile
parent136003c44d4f1a5c6e10e7dacfc01ccf0b285bab (diff)
openvswitch: fix libunbound dependency check
The ifeq check for CONFIG_OPENVSWITCH_WITH_LIBUNBOUND does not evaluate correctly within the menuconfig, resulting in libunbound not being selected, resulting in a failing libunbound.so.8 dependency. Instead add this condition:dependency in the manner defined in the OpenWrt developer guide. Signed-off-by: Matthew Hagan <mathagan@fb.com>
Diffstat (limited to 'net/openvswitch/Makefile')
-rw-r--r--net/openvswitch/Makefile7
1 files changed, 3 insertions, 4 deletions
diff --git a/net/openvswitch/Makefile b/net/openvswitch/Makefile
index f9c212da1..abd202eda 100644
--- a/net/openvswitch/Makefile
+++ b/net/openvswitch/Makefile
@@ -153,10 +153,9 @@ $(eval $(call OvsKmodPackageTemplate,openvswitch-lisp-intree))
#
ovs_libopenvswitch_title:=Open vSwitch (libopenvswitch.so)
ovs_libopenvswitch_hidden:=1
-ovs_libopenvswitch_depends:= +libatomic +libopenssl +!(arc||arceb):libunwind
-ifeq ($(CONFIG_OPENVSWITCH_WITH_LIBUNBOUND),y)
-ovs_libopenvswitch_depends+=+libunbound
-endif
+ovs_libopenvswitch_depends:= \
+ +libatomic +libopenssl +OPENVSWITCH_WITH_LIBUNBOUND:libunbound \
+ +!(arc||arceb):libunwind
ovs_libopenvswitch_files:=usr/lib/libopenvswitch*.so*
$(eval $(call OvsPackageTemplate,libopenvswitch))