aboutsummaryrefslogtreecommitdiff
path: root/net/openvswitch/Makefile
diff options
context:
space:
mode:
authorMatthew Hagan <mathagan@fb.com>2021-12-15 15:27:37 +0000
committerYousong Zhou <yszhou4tech@gmail.com>2021-12-16 13:25:37 +0800
commit136003c44d4f1a5c6e10e7dacfc01ccf0b285bab (patch)
tree894f9aaaf453a4116015827f909cd6a649844e6f /net/openvswitch/Makefile
parent4e5eb5e0b92ea423868e60dfa90ca049a3669244 (diff)
openvswitch: Change dependency from append to definition
ovs_libovsdb_depends and ovs_libofproto_depends append the libatomic dependency. However in these cases these variables were not previously defined and thus a reader may search the Makefile for the definition. Therefore change the operator to explicitly define these dependency variables, rather than append. In addition add a space after operator to improve readability and conform to other dependency definitions in the Makefile. Signed-off-by: Matthew Hagan <mathagan@fb.com>
Diffstat (limited to 'net/openvswitch/Makefile')
-rw-r--r--net/openvswitch/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/net/openvswitch/Makefile b/net/openvswitch/Makefile
index 8b0a0c828..f9c212da1 100644
--- a/net/openvswitch/Makefile
+++ b/net/openvswitch/Makefile
@@ -163,14 +163,14 @@ $(eval $(call OvsPackageTemplate,libopenvswitch))
ovs_libofproto_title:=Open vSwitch (libofproto.so libsflow.so)
ovs_libofproto_hidden:=1
-ovs_libofproto_depends+=+libatomic
+ovs_libofproto_depends:= +libatomic
ovs_libofproto_files:=usr/lib/libofproto*.so* usr/lib/libsflow*.so*
$(eval $(call OvsPackageTemplate,libofproto))
ovs_libovsdb_title:=Open vSwitch (libovsdb.so)
ovs_libovsdb_hidden:=1
-ovs_libovsdb_depends+=+libatomic
+ovs_libovsdb_depends:= +libatomic
ovs_libovsdb_files:=usr/lib/libovsdb*.so*
$(eval $(call OvsPackageTemplate,libovsdb))