aboutsummaryrefslogtreecommitdiff
path: root/net/mosh/Makefile
diff options
context:
space:
mode:
authorAndre Heider <a.heider@gmail.com>2023-03-23 09:27:01 +0100
committerAndre Heider <a.heider@gmail.com>2023-04-08 08:38:54 +0200
commite7d9c865036d7bc2ac30604e8573f25ae601aed1 (patch)
tree5efb8a25df387e8e79356447c648ecc3306176b3 /net/mosh/Makefile
parent35f4ef76e0c88b690ec55f26aed072c4c5989eff (diff)
treewide: refactor to use PKG_BUILD_FLAGS:=lto
See commit 07730ff3 "treewide: add support for "lto" in PKG_BUILD_FLAGS" on the main repository. Note: Some packages only added `-flto` to CFLAGS and not LDFLAGS. This fixes it and properly enables LTO. Signed-off-by: Andre Heider <a.heider@gmail.com>
Diffstat (limited to 'net/mosh/Makefile')
-rw-r--r--net/mosh/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/net/mosh/Makefile b/net/mosh/Makefile
index 53b8659f4..0b840f399 100644
--- a/net/mosh/Makefile
+++ b/net/mosh/Makefile
@@ -22,7 +22,7 @@ PKG_LICENSE_FILES:=COPYING
PKG_INSTALL:=1
PKG_BUILD_PARALLEL:=1
PKG_BUILD_DEPENDS:=protobuf/host
-PKG_BUILD_FLAGS:=gc-sections
+PKG_BUILD_FLAGS:=gc-sections lto
include $(INCLUDE_DIR)/package.mk
@@ -96,7 +96,7 @@ CONFIGURE_ARGS += \
CONFIGURE_VARS += \
ac_cv_have_decl_ffs=yes
-TARGET_CXXFLAGS += -flto -std=c++11
+TARGET_CXXFLAGS += -std=c++11
TARGET_LDFLAGS += -lncurses
define Package/mosh-client/install