aboutsummaryrefslogtreecommitdiff
path: root/net/mosh/Makefile
diff options
context:
space:
mode:
authorAndre Heider <a.heider@gmail.com>2023-03-23 09:09:13 +0100
committerAndre Heider <a.heider@gmail.com>2023-04-08 08:38:54 +0200
commit35f4ef76e0c88b690ec55f26aed072c4c5989eff (patch)
treec5b36bb3b16488c4546c3c283b8a6020e3966143 /net/mosh/Makefile
parent565866a47210c9711c29173052063779b6d3bcfc (diff)
treewide: refactor to use PKG_BUILD_FLAGS:=gc-sections
See commit da370098 "treewide: add support for "gc-sections" in PKG_BUILD_FLAGS" on the main repository. Note: This only touches packages which use all three parts (-ffunction-sections, -fdata-sections and -Wl,--gc-sections) enabled by this build flag. Some packages only use a subset, and these are left unchanged for now. Signed-off-by: Andre Heider <a.heider@gmail.com>
Diffstat (limited to 'net/mosh/Makefile')
-rw-r--r--net/mosh/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/net/mosh/Makefile b/net/mosh/Makefile
index 1c3341a32..53b8659f4 100644
--- a/net/mosh/Makefile
+++ b/net/mosh/Makefile
@@ -22,6 +22,7 @@ PKG_LICENSE_FILES:=COPYING
PKG_INSTALL:=1
PKG_BUILD_PARALLEL:=1
PKG_BUILD_DEPENDS:=protobuf/host
+PKG_BUILD_FLAGS:=gc-sections
include $(INCLUDE_DIR)/package.mk
@@ -95,8 +96,8 @@ CONFIGURE_ARGS += \
CONFIGURE_VARS += \
ac_cv_have_decl_ffs=yes
-TARGET_CXXFLAGS += -ffunction-sections -fdata-sections -flto -std=c++11
-TARGET_LDFLAGS += -Wl,--gc-sections -lncurses
+TARGET_CXXFLAGS += -flto -std=c++11
+TARGET_LDFLAGS += -lncurses
define Package/mosh-client/install
$(INSTALL_DIR) $(1)/usr/bin