aboutsummaryrefslogtreecommitdiff
path: root/net/mosh/Makefile
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-03-17 16:15:42 -0700
committerRosen Penev <rosenp@gmail.com>2020-03-17 17:49:01 -0700
commit1ead64489b7c18d3c58d7e24da079c405e0eaf50 (patch)
tree19632f39d978d5c8571fdb9f0834ef4ca9888409 /net/mosh/Makefile
parentd6583e3d66b1007479d3ee48d2d8233db357cdef (diff)
mosh: use mips16 and remove configure patch
MIPS16 is not needed here. Removed configure patch and replaced with a configure var. Removed autoreconf as configure is no longer being patched. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'net/mosh/Makefile')
-rw-r--r--net/mosh/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/net/mosh/Makefile b/net/mosh/Makefile
index b4a666b87..8641b21ce 100644
--- a/net/mosh/Makefile
+++ b/net/mosh/Makefile
@@ -19,11 +19,9 @@ PKG_MAINTAINER:=Rosen Penev <rosenp@gmail.com>
PKG_LICENSE:=GPL-3.0-or-later
PKG_LICENSE_FILES:=COPYING
-PKG_FIXUP:=autoreconf
PKG_INSTALL:=1
PKG_BUILD_PARALLEL:=1
PKG_BUILD_DEPENDS:=protobuf/host
-PKG_USE_MIPS16:=0
include $(INCLUDE_DIR)/package.mk
@@ -93,6 +91,9 @@ CONFIGURE_ARGS += \
--disable-hardening \
--without-utempter
+CONFIGURE_VARS += \
+ ac_cv_have_decl_ffs=yes
+
TARGET_CXXFLAGS += -ffunction-sections -fdata-sections -flto -std=c++11
TARGET_LDFLAGS += -Wl,--gc-sections -lncurses