aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net/mosh/Makefile5
-rw-r--r--net/mosh/patches/010-ffs.patch12
2 files changed, 3 insertions, 14 deletions
diff --git a/net/mosh/Makefile b/net/mosh/Makefile
index b4a666b87..8641b21ce 100644
--- a/net/mosh/Makefile
+++ b/net/mosh/Makefile
@@ -19,11 +19,9 @@ PKG_MAINTAINER:=Rosen Penev <rosenp@gmail.com>
PKG_LICENSE:=GPL-3.0-or-later
PKG_LICENSE_FILES:=COPYING
-PKG_FIXUP:=autoreconf
PKG_INSTALL:=1
PKG_BUILD_PARALLEL:=1
PKG_BUILD_DEPENDS:=protobuf/host
-PKG_USE_MIPS16:=0
include $(INCLUDE_DIR)/package.mk
@@ -93,6 +91,9 @@ CONFIGURE_ARGS += \
--disable-hardening \
--without-utempter
+CONFIGURE_VARS += \
+ ac_cv_have_decl_ffs=yes
+
TARGET_CXXFLAGS += -ffunction-sections -fdata-sections -flto -std=c++11
TARGET_LDFLAGS += -Wl,--gc-sections -lncurses
diff --git a/net/mosh/patches/010-ffs.patch b/net/mosh/patches/010-ffs.patch
deleted file mode 100644
index 7df9a0754..000000000
--- a/net/mosh/patches/010-ffs.patch
+++ /dev/null
@@ -1,12 +0,0 @@
---- a/configure.ac
-+++ b/configure.ac
-@@ -425,7 +425,8 @@ AC_CHECK_DECL([mach_absolute_time],
- AC_CHECK_DECLS([__builtin_ctz])
-
- AC_CHECK_DECLS([ffs], [], [],
-- [[#include <strings.h>]])
-+ [[#define _GNU_SOURCE
-+#include <strings.h>]])
-
- AC_CHECK_DECLS([be64toh, betoh64, bswap64, __builtin_bswap64], [], [],
- [[#if defined(HAVE_ENDIAN_H)