aboutsummaryrefslogtreecommitdiff
path: root/net/hcxdumptool
diff options
context:
space:
mode:
authorAndreas Nilsen <adde88@gmail.com>2019-07-02 15:23:31 +0200
committerAndreas Nilsen <adde88@gmail.com>2019-07-02 16:16:44 +0200
commit6f6457fb373aa71a3546f43019c493f3b15fafc2 (patch)
treeab5266b70c31c114f9df82a2e2b2a7d3d02e065c /net/hcxdumptool
parent9e4fc185e2db4bcaabeffe08dc4da91802c18f6b (diff)
hcxtools: Changes to the Makefile, as suggested.
- Now using codeload as suggested. - Removed PKG_BUILD_PARALLEL, and PKG_USE_MIPS16:=0 as it was no longer needed to build the latest version successfully. - Moved PKG_MAINTAINER to top. - Use INSTALL_BIN instead of CP - Added PKG_LICENSE and PKG_LICENSE_FILES - Fixed a typo in TITLE - DCO should be fixed now. Signed-off-by: Andreas Nilsen <adde88@gmail.com>
Diffstat (limited to 'net/hcxdumptool')
-rw-r--r--net/hcxdumptool/Makefile16
1 files changed, 7 insertions, 9 deletions
diff --git a/net/hcxdumptool/Makefile b/net/hcxdumptool/Makefile
index be3b27dee..1eb34b40d 100644
--- a/net/hcxdumptool/Makefile
+++ b/net/hcxdumptool/Makefile
@@ -1,5 +1,4 @@
#
-# Copyright (C) 2009-2014 OpenWrt.org
# Copyright (C) 2019 Andreas Nilsen <adde88@gmail.com>
#
# This is free software, licensed under the GNU General Public License v2.
@@ -12,13 +11,13 @@ PKG_NAME:=hcxdumptool
PKG_VERSION:=5.1.7
PKG_RELEASE:=1
-PKG_SOURCE:=$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=https://github.com/ZerBea/$(PKG_NAME)/archive/
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=https://codeload.github.com/zerbea/hcxdumptool/tar.gz/$(PKG_VERSION)?
PKG_HASH:=6ac996a506cb312a5f1c5987f30a4a80c793993908750f69f2df51056f961269
-PKG_BUILD_PARALLEL:=1
-
-PKG_USE_MIPS16:=0
+PKG_MAINTAINER:=Andreas Nilsen <adde88@gmail.com>
+PKG_LICENSE:=MIT
+PKG_LICENSE_FILE:=license.txt
include $(INCLUDE_DIR)/package.mk
@@ -27,9 +26,8 @@ define Package/hcxdumptool
CATEGORY:=Network
DEPENDS:=+libpcap
TITLE:=hcxdumptool
- URL:=https://github.com/ZerBea/hcxdumptool.git
+ URL:=https://github.com/ZerBea/hcxdumptool
SUBMENU:=wireless
- MAINTAINER:=Andreas Nilsen <adde88@gmail.com>
endef
define Package/hcxdumptool/description
@@ -48,7 +46,7 @@ endef
define Package/hcxdumptool/install
$(INSTALL_DIR) $(1)/sbin
- $(CP) $(PKG_BUILD_DIR)/hcxdumptool $(1)/sbin/
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/hcxdumptool $(1)/sbin/
endef
$(eval $(call BuildPackage,hcxdumptool))