aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net/hcxdumptool/Makefile16
-rw-r--r--net/hcxtools/Makefile52
2 files changed, 33 insertions, 35 deletions
diff --git a/net/hcxdumptool/Makefile b/net/hcxdumptool/Makefile
index be3b27dee..1eb34b40d 100644
--- a/net/hcxdumptool/Makefile
+++ b/net/hcxdumptool/Makefile
@@ -1,5 +1,4 @@
#
-# Copyright (C) 2009-2014 OpenWrt.org
# Copyright (C) 2019 Andreas Nilsen <adde88@gmail.com>
#
# This is free software, licensed under the GNU General Public License v2.
@@ -12,13 +11,13 @@ PKG_NAME:=hcxdumptool
PKG_VERSION:=5.1.7
PKG_RELEASE:=1
-PKG_SOURCE:=$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=https://github.com/ZerBea/$(PKG_NAME)/archive/
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=https://codeload.github.com/zerbea/hcxdumptool/tar.gz/$(PKG_VERSION)?
PKG_HASH:=6ac996a506cb312a5f1c5987f30a4a80c793993908750f69f2df51056f961269
-PKG_BUILD_PARALLEL:=1
-
-PKG_USE_MIPS16:=0
+PKG_MAINTAINER:=Andreas Nilsen <adde88@gmail.com>
+PKG_LICENSE:=MIT
+PKG_LICENSE_FILE:=license.txt
include $(INCLUDE_DIR)/package.mk
@@ -27,9 +26,8 @@ define Package/hcxdumptool
CATEGORY:=Network
DEPENDS:=+libpcap
TITLE:=hcxdumptool
- URL:=https://github.com/ZerBea/hcxdumptool.git
+ URL:=https://github.com/ZerBea/hcxdumptool
SUBMENU:=wireless
- MAINTAINER:=Andreas Nilsen <adde88@gmail.com>
endef
define Package/hcxdumptool/description
@@ -48,7 +46,7 @@ endef
define Package/hcxdumptool/install
$(INSTALL_DIR) $(1)/sbin
- $(CP) $(PKG_BUILD_DIR)/hcxdumptool $(1)/sbin/
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/hcxdumptool $(1)/sbin/
endef
$(eval $(call BuildPackage,hcxdumptool))
diff --git a/net/hcxtools/Makefile b/net/hcxtools/Makefile
index b6cf970bf..6ea883f94 100644
--- a/net/hcxtools/Makefile
+++ b/net/hcxtools/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2009-2014 OpenWrt.org
+# Copyright (C) 2019 Andreas Nilsen <adde88@gmail.com>
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -11,11 +11,13 @@ PKG_NAME:=hcxtools
PKG_VERSION:=5.1.6
PKG_RELEASE:=1
-PKG_SOURCE:=$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=https://github.com/ZerBea/$(PKG_NAME)/archive/
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=https://codeload.github.com/zerbea/hcxtools/tar.gz/$(PKG_VERSION)?
PKG_HASH:=19d2800c6f9339dd552ebc3e7195860f208a9856340b4db1aeaeb4a234557ca6
-PKG_BUILD_PARALLEL:=1
+PKG_MAINTAINER:=Andreas Nilsen <adde88@gmail.com>
+PKG_LICENSE:=MIT
+PKG_LICENSE_FILE:=license.txt
include $(INCLUDE_DIR)/package.mk
@@ -23,10 +25,9 @@ define Package/hcxtools
SECTION:=net
CATEGORY:=Network
DEPENDS:=+libpthread +libpcap +zlib +libcurl +libopenssl
- TITLE:= hcxtools
- URL:=https://github.com/ZerBea/hcxtools.git
+ TITLE:=hcxtools
+ URL:=https://github.com/ZerBea/hcxtools
SUBMENU:=wireless
- MAINTAINER:=Andreas Nilsen <adde88@gmail.com>
endef
define Package/hcxtools/description
@@ -43,25 +44,24 @@ endef
define Package/hcxtools/install
$(INSTALL_DIR) $(1)/sbin
$(INSTALL_DIR) $(1)/etc
- $(CP) $(PKG_BUILD_DIR)/wlanwkp2hcx $(1)/sbin/
- $(CP) $(PKG_BUILD_DIR)/wlanpmk2hcx $(1)/sbin/
- $(CP) $(PKG_BUILD_DIR)/wlanhcxmnc $(1)/sbin/
- $(CP) $(PKG_BUILD_DIR)/wlanhcx2essid $(1)/sbin/
- $(CP) $(PKG_BUILD_DIR)/wlanjohn2hcx $(1)/sbin/
- $(CP) $(PKG_BUILD_DIR)/hcxpcaptool $(1)/sbin/
- $(CP) $(PKG_BUILD_DIR)/wlanhcx2john $(1)/sbin/
- $(CP) $(PKG_BUILD_DIR)/hcxpsktool $(1)/sbin/
- $(CP) $(PKG_BUILD_DIR)/wlancow2hcxpmk $(1)/sbin/
- $(CP) $(PKG_BUILD_DIR)/wlanhcxinfo $(1)/sbin/
- $(CP) $(PKG_BUILD_DIR)/hcxhash2cap $(1)/sbin/
- $(CP) $(PKG_BUILD_DIR)/hcxhashcattool $(1)/sbin/
- $(CP) $(PKG_BUILD_DIR)/wlanhashhcx $(1)/sbin/
- $(CP) $(PKG_BUILD_DIR)/wlancap2wpasec $(1)/sbin/
- $(CP) $(PKG_BUILD_DIR)/wlanhc2hcx $(1)/sbin/
- $(CP) $(PKG_BUILD_DIR)/hcxwltool $(1)/sbin/
- $(CP) $(PKG_BUILD_DIR)/whoismac $(1)/sbin/
- $(CP) $(PKG_BUILD_DIR)/wlancap2wpasec $(1)/sbin/
-# $(CP) $(PKG_BUILD_DIR)/usefulscripts/hcxgrep.py $(1)/sbin/hcxgrep
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/wlanwkp2hcx $(1)/sbin/
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/wlanpmk2hcx $(1)/sbin/
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/wlanhcxmnc $(1)/sbin/
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/wlanhcx2essid $(1)/sbin/
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/wlanjohn2hcx $(1)/sbin/
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/hcxpcaptool $(1)/sbin/
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/wlanhcx2john $(1)/sbin/
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/hcxpsktool $(1)/sbin/
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/wlancow2hcxpmk $(1)/sbin/
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/wlanhcxinfo $(1)/sbin/
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/hcxhash2cap $(1)/sbin/
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/hcxhashcattool $(1)/sbin/
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/wlanhashhcx $(1)/sbin/
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/wlancap2wpasec $(1)/sbin/
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/wlanhc2hcx $(1)/sbin/
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/hcxwltool $(1)/sbin/
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/whoismac $(1)/sbin/
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/wlancap2wpasec $(1)/sbin/
endef
$(eval $(call BuildPackage,hcxtools))