aboutsummaryrefslogtreecommitdiff
path: root/net/bitlbee
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2019-06-27 17:03:14 -0700
committerRosen Penev <rosenp@gmail.com>2019-07-08 14:38:31 -0700
commit16c908c107f394f45ab1190d0ad2457c8c6a8d19 (patch)
tree29c4401aac05ce6e930c269910e9785dcc8f5b3a /net/bitlbee
parent7fb0a94fb5af8f7a52c58a9472d2bc2a2a70ac2e (diff)
bitlbee: Update to 3.6
Removed upstreamed patch. Removed mirror. It seems it has a wrong HTTPS certificate. Added PKG_BUILD_PARALLEL for faster compilation. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'net/bitlbee')
-rw-r--r--net/bitlbee/Makefile16
-rw-r--r--net/bitlbee/patches/010-openssl-1.1-compatibility.patch50
2 files changed, 8 insertions, 58 deletions
diff --git a/net/bitlbee/Makefile b/net/bitlbee/Makefile
index 90b852760..cab595161 100644
--- a/net/bitlbee/Makefile
+++ b/net/bitlbee/Makefile
@@ -8,19 +8,19 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=bitlbee
-PKG_VERSION:=3.5.1
-PKG_RELEASE:=2
+PKG_VERSION:=3.6
+PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://get.bitlbee.org/src/ \
- http://distcache.FreeBSD.org/local-distfiles/brix/
-PKG_HASH:=9636d7fd89ebb3756c13a9a3387736ca6d56ccf66ec0580d512f07b21db0fa69
+PKG_SOURCE_URL:=https://get.bitlbee.org/src
+PKG_HASH:=9f15de46f29b46bf1e39fc50bdf4515e71b17f551f3955094c5da792d962107e
PKG_MAINTAINER:=Nikil Mehta <nikil.mehta@gmail.com>
-PKG_LICENSE:=GPL-2.0
+PKG_LICENSE:=GPL-2.0-or-later
PKG_LICENSE_FILES:=COPYING
PKG_INSTALL:=1
+PKG_BUILD_PARALLEL:=1
include $(INCLUDE_DIR)/package.mk
include $(INCLUDE_DIR)/nls.mk
@@ -30,7 +30,7 @@ define Package/bitlbee
CATEGORY:=Network
SUBMENU:=Instant Messaging
TITLE:=An IRC to other chat networks gateway
- URL:=http://www.bitlbee.org/
+ URL:=https://www.bitlbee.org/
DEPENDS:=+glib2 +libopenssl $(ICONV_DEPENDS) $(INTL_DEPENDS)
endef
@@ -58,7 +58,7 @@ define Build/Install
$(call Build/Install/Default,install install-etc)
endef
-define Package/bitlbee/install
+define Package/bitlbee/install
$(INSTALL_DIR) $(1)/usr/sbin
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/bitlbee $(1)/usr/sbin/
$(INSTALL_DIR) $(1)/etc/bitlbee
diff --git a/net/bitlbee/patches/010-openssl-1.1-compatibility.patch b/net/bitlbee/patches/010-openssl-1.1-compatibility.patch
deleted file mode 100644
index 02327e6f2..000000000
--- a/net/bitlbee/patches/010-openssl-1.1-compatibility.patch
+++ /dev/null
@@ -1,50 +0,0 @@
---- a/lib/ssl_openssl.c
-+++ b/lib/ssl_openssl.c
-@@ -64,11 +64,17 @@ void ssl_init(void)
- {
- const SSL_METHOD *meth;
-
-+#if OPENSSL_VERSION_NUMBER < 0x10100000L
- SSL_library_init();
-
- meth = SSLv23_client_method();
- ssl_ctx = SSL_CTX_new(meth);
- SSL_CTX_set_options(ssl_ctx, SSL_OP_NO_SSLv2 | SSL_OP_NO_SSLv3);
-+#else
-+ meth = TLS_client_method();
-+ ssl_ctx = SSL_CTX_new(meth);
-+ SSL_CTX_set_min_proto_version(ssl_ctx, TLS1_VERSION);
-+#endif
-
- initialized = TRUE;
- }
-@@ -300,20 +306,20 @@ size_t ssl_des3_encrypt(const unsigned c
- const unsigned char *iv, unsigned char **res)
- {
- int output_length = 0;
-- EVP_CIPHER_CTX ctx;
-+ EVP_CIPHER_CTX *ctx;
-
- *res = g_new0(unsigned char, 72);
-
- /* Don't set key or IV because we will modify the parameters */
-- EVP_CIPHER_CTX_init(&ctx);
-- EVP_CipherInit_ex(&ctx, EVP_des_ede3_cbc(), NULL, NULL, NULL, 1);
-- EVP_CIPHER_CTX_set_key_length(&ctx, key_len);
-- EVP_CIPHER_CTX_set_padding(&ctx, 0);
-+ ctx = EVP_CIPHER_CTX_new();
-+ EVP_CipherInit_ex(ctx, EVP_des_ede3_cbc(), NULL, NULL, NULL, 1);
-+ EVP_CIPHER_CTX_set_key_length(ctx, key_len);
-+ EVP_CIPHER_CTX_set_padding(ctx, 0);
- /* We finished modifying parameters so now we can set key and IV */
-- EVP_CipherInit_ex(&ctx, NULL, NULL, key, iv, 1);
-- EVP_CipherUpdate(&ctx, *res, &output_length, input, input_len);
-- EVP_CipherFinal_ex(&ctx, *res, &output_length);
-- EVP_CIPHER_CTX_cleanup(&ctx);
-+ EVP_CipherInit_ex(ctx, NULL, NULL, key, iv, 1);
-+ EVP_CipherUpdate(ctx, *res, &output_length, input, input_len);
-+ EVP_CipherFinal_ex(ctx, *res, &output_length);
-+ EVP_CIPHER_CTX_free(ctx);
- //EVP_cleanup();
-
- return output_length;