aboutsummaryrefslogtreecommitdiff
path: root/net/apinger/patches/010-poll.patch
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2019-06-28 10:53:53 -0700
committerRosen Penev <rosenp@gmail.com>2019-06-28 11:38:42 -0700
commitdff6d2639eabb93e2d3782bfc1262bb6f7dccc33 (patch)
tree1a3719558a825992b5c3bdffa018e419f444db34 /net/apinger/patches/010-poll.patch
parent7fb0a94fb5af8f7a52c58a9472d2bc2a2a70ac2e (diff)
apinger: Update to latest git revision
This project seems abandoned. Updated to latest version. Also cleaned up the Makefile quite a bit. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'net/apinger/patches/010-poll.patch')
-rw-r--r--net/apinger/patches/010-poll.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/net/apinger/patches/010-poll.patch b/net/apinger/patches/010-poll.patch
new file mode 100644
index 000000000..760079e5a
--- /dev/null
+++ b/net/apinger/patches/010-poll.patch
@@ -0,0 +1,24 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -23,7 +23,7 @@ AC_HEADER_SYS_WAIT
+ AC_CHECK_HEADERS([arpa/inet.h errno.h malloc.h \
+ stddef.h stdlib.h string.h sys/socket.h \
+ sys/time.h syslog.h unistd.h time.h \
+- assert.h sys/poll.h signal.h pwd.h grp.h stdarg.h\
++ assert.h poll.h signal.h pwd.h grp.h stdarg.h\
+ limits.h sys/wait.h sched.h sys/ioctl.h sys/uio.h])
+ AC_HEADER_TIME
+
+--- a/src/apinger.c
++++ b/src/apinger.c
+@@ -33,8 +33,8 @@
+ #ifdef HAVE_SYS_WAIT_H
+ # include <sys/wait.h>
+ #endif
+-#ifdef HAVE_SYS_POLL_H
+-# include <sys/poll.h>
++#ifdef HAVE_POLL_H
++# include <poll.h>
+ #endif
+ #ifdef HAVE_ARPA_INET_H
+ # include <arpa/inet.h>