aboutsummaryrefslogtreecommitdiff
path: root/net/apinger/patches
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2019-06-28 10:53:53 -0700
committerRosen Penev <rosenp@gmail.com>2019-06-28 11:38:42 -0700
commitdff6d2639eabb93e2d3782bfc1262bb6f7dccc33 (patch)
tree1a3719558a825992b5c3bdffa018e419f444db34 /net/apinger/patches
parent7fb0a94fb5af8f7a52c58a9472d2bc2a2a70ac2e (diff)
apinger: Update to latest git revision
This project seems abandoned. Updated to latest version. Also cleaned up the Makefile quite a bit. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'net/apinger/patches')
-rw-r--r--net/apinger/patches/001-autoreconf.patch13
-rw-r--r--net/apinger/patches/002-run_as_user.patch6
-rw-r--r--net/apinger/patches/003-no_docs.patch4
-rw-r--r--net/apinger/patches/010-poll.patch24
4 files changed, 29 insertions, 18 deletions
diff --git a/net/apinger/patches/001-autoreconf.patch b/net/apinger/patches/001-autoreconf.patch
deleted file mode 100644
index cb5bd454d..000000000
--- a/net/apinger/patches/001-autoreconf.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- apinger-0.6.1/acinclude.m4 2003-10-21 12:44:48.000000000 +0000
-+++ apinger-0.6.1/acinclude.m4 2015-04-08 15:27:37.451903960 +0000
-@@ -39,9 +39,7 @@
- [$jk_inet_includes
- $jk_icmp_includes])
-
--AC_CHECK_MEMBERS([struct icmp.icmp_type, struct icmp.icmp_code,\
--struct icmp.icmp_cksum, struct icmp.icmp_seq,\
--struct icmp.icmp_id],[],
-+AC_CHECK_MEMBERS([struct icmp.icmp_type, struct icmp.icmp_code,struct icmp.icmp_cksum, struct icmp.icmp_seq,struct icmp.icmp_id],[],
- AC_MSG_ERROR(struct icmp not defined or not compatible),
- [$jk_inet_includes
- $jk_icmp_includes])
diff --git a/net/apinger/patches/002-run_as_user.patch b/net/apinger/patches/002-run_as_user.patch
index 16d64acc5..ca36e97a6 100644
--- a/net/apinger/patches/002-run_as_user.patch
+++ b/net/apinger/patches/002-run_as_user.patch
@@ -1,6 +1,6 @@
---- apinger-0.6.1/src/apinger.conf.orig 2015-04-08 16:05:24.558919722 +0000
-+++ apinger-0.6.1/src/apinger.conf 2015-04-08 16:07:47.089170236 +0000
-@@ -9,7 +9,7 @@
+--- a/src/apinger.conf
++++ b/src/apinger.conf
+@@ -8,7 +8,7 @@
## User and group the pinger should run as
user "nobody"
diff --git a/net/apinger/patches/003-no_docs.patch b/net/apinger/patches/003-no_docs.patch
index c08f44de7..ecfca2d7e 100644
--- a/net/apinger/patches/003-no_docs.patch
+++ b/net/apinger/patches/003-no_docs.patch
@@ -1,5 +1,5 @@
---- apinger-0.6.1/Makefile.am.orig 2015-04-08 16:47:40.999990050 +0000
-+++ apinger-0.6.1/Makefile.am 2015-04-08 16:48:07.565220137 +0000
+--- a/Makefile.am
++++ b/Makefile.am
@@ -1,7 +1,7 @@
EXTRA_DIST = autogen.sh TODO BUGS
diff --git a/net/apinger/patches/010-poll.patch b/net/apinger/patches/010-poll.patch
new file mode 100644
index 000000000..760079e5a
--- /dev/null
+++ b/net/apinger/patches/010-poll.patch
@@ -0,0 +1,24 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -23,7 +23,7 @@ AC_HEADER_SYS_WAIT
+ AC_CHECK_HEADERS([arpa/inet.h errno.h malloc.h \
+ stddef.h stdlib.h string.h sys/socket.h \
+ sys/time.h syslog.h unistd.h time.h \
+- assert.h sys/poll.h signal.h pwd.h grp.h stdarg.h\
++ assert.h poll.h signal.h pwd.h grp.h stdarg.h\
+ limits.h sys/wait.h sched.h sys/ioctl.h sys/uio.h])
+ AC_HEADER_TIME
+
+--- a/src/apinger.c
++++ b/src/apinger.c
+@@ -33,8 +33,8 @@
+ #ifdef HAVE_SYS_WAIT_H
+ # include <sys/wait.h>
+ #endif
+-#ifdef HAVE_SYS_POLL_H
+-# include <sys/poll.h>
++#ifdef HAVE_POLL_H
++# include <poll.h>
+ #endif
+ #ifdef HAVE_ARPA_INET_H
+ # include <arpa/inet.h>