aboutsummaryrefslogtreecommitdiff
path: root/multimedia
diff options
context:
space:
mode:
authorIan Leonard <antonlacon@gmail.com>2014-08-28 13:16:59 -0700
committerIan Leonard <antonlacon@gmail.com>2014-10-11 22:13:15 -0700
commitad20ef11473c7d3a84d050f3d09cd968a562b84f (patch)
tree9a523bb8bc0a05a5e0dd6f6d384750d4278ad825 /multimedia
parent28f8dfc928dbcf7b288987f15b59562fa4a98dc8 (diff)
ffmpeg: add libopus support
Signed-off-by: Ian Leonard <antonlacon@gmail.com>
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/ffmpeg/Config.in4
-rw-r--r--multimedia/ffmpeg/Makefile11
2 files changed, 13 insertions, 2 deletions
diff --git a/multimedia/ffmpeg/Config.in b/multimedia/ffmpeg/Config.in
index 3e6e2091d..c01498778 100644
--- a/multimedia/ffmpeg/Config.in
+++ b/multimedia/ffmpeg/Config.in
@@ -60,6 +60,7 @@ config FFMPEG_CUSTOM_AUDIO_DEC_SUPPORT
select FFMPEG_CUSTOM_DECODER_ape
select FFMPEG_CUSTOM_DECODER_atrac3
select FFMPEG_CUSTOM_DECODER_flac
+ select FFMPEG_CUSTOM_SELECT_libopus
select FFMPEG_CUSTOM_DECODER_mp2
select FFMPEG_CUSTOM_DECODER_mp3
select FFMPEG_CUSTOM_DECODER_mpc7
@@ -108,6 +109,9 @@ config FFMPEG_CUSTOM_AUDIO_DEC_SUPPORT
comment "External Libraries ---"
+config FFMPEG_CUSTOM_SELECT_libopus
+ bool "Opus"
+
config FFMPEG_CUSTOM_SELECT_speex
bool "Speex"
diff --git a/multimedia/ffmpeg/Makefile b/multimedia/ffmpeg/Makefile
index 3923cc820..ab1beb640 100644
--- a/multimedia/ffmpeg/Makefile
+++ b/multimedia/ffmpeg/Makefile
@@ -289,7 +289,7 @@ endef
define Package/libffmpeg-custom
$(call Package/libffmpeg/Default)
TITLE+= (custom)
- DEPENDS+= @DEVEL +libspeex
+ DEPENDS+= @DEVEL +libopus +libspeex
VARIANT:=custom
MENU:=1
endef
@@ -308,7 +308,7 @@ endef
define Package/libffmpeg-audio-dec
$(call Package/libffmpeg/Default)
TITLE+= (audio)
- DEPENDS+= @DEVEL +libspeex
+ DEPENDS+= @DEVEL +libopus +libspeex
VARIANT:=audio-dec
endef
@@ -428,6 +428,12 @@ ifeq ($(CONFIG_FFMPEG_CUSTOM_SELECT_adpcm),y)
endif
+ifeq ($(CONFIG_FFMPEG_CUSTOM_SELECT_libopus),y)
+ FFMPEG_CONFIGURE+= \
+ --enable-libopus --enable-decoder=libopus \
+
+endif
+
ifeq ($(CONFIG_FFMPEG_CUSTOM_SELECT_speex),y)
FFMPEG_CONFIGURE+= \
--enable-libspeex --enable-decoder=libspeex \
@@ -454,6 +460,7 @@ ifeq ($(BUILD_VARIANT),audio-dec)
$(call FFMPEG_ENABLE,demuxer,$(FFMPEG_AUDIO_DEMUXERS)) \
$(call FFMPEG_ENABLE,parser,$(FFMPEG_AUDIO_PARSERS)) \
$(call FFMPEG_ENABLE,protocol,$(FFMPEG_AUDIO_PROTOCOLS)) \
+ --enable-libopus --enable-decoder=libopus \
--enable-libspeex --enable-decoder=libspeex \
--disable-decoder=pcm_bluray,pcm_dvd \