From ad20ef11473c7d3a84d050f3d09cd968a562b84f Mon Sep 17 00:00:00 2001
From: Ian Leonard <antonlacon@gmail.com>
Date: Thu, 28 Aug 2014 13:16:59 -0700
Subject: ffmpeg: add libopus support

Signed-off-by: Ian Leonard <antonlacon@gmail.com>
---
 multimedia/ffmpeg/Config.in |  4 ++++
 multimedia/ffmpeg/Makefile  | 11 +++++++++--
 2 files changed, 13 insertions(+), 2 deletions(-)

(limited to 'multimedia')

diff --git a/multimedia/ffmpeg/Config.in b/multimedia/ffmpeg/Config.in
index 3e6e2091d..c01498778 100644
--- a/multimedia/ffmpeg/Config.in
+++ b/multimedia/ffmpeg/Config.in
@@ -60,6 +60,7 @@ config FFMPEG_CUSTOM_AUDIO_DEC_SUPPORT
 	select FFMPEG_CUSTOM_DECODER_ape
 	select FFMPEG_CUSTOM_DECODER_atrac3
 	select FFMPEG_CUSTOM_DECODER_flac
+	select FFMPEG_CUSTOM_SELECT_libopus
 	select FFMPEG_CUSTOM_DECODER_mp2
 	select FFMPEG_CUSTOM_DECODER_mp3
 	select FFMPEG_CUSTOM_DECODER_mpc7
@@ -108,6 +109,9 @@ config FFMPEG_CUSTOM_AUDIO_DEC_SUPPORT
 
 comment "External Libraries ---"
 
+config FFMPEG_CUSTOM_SELECT_libopus
+	bool "Opus"
+
 config FFMPEG_CUSTOM_SELECT_speex
 	bool "Speex"
 
diff --git a/multimedia/ffmpeg/Makefile b/multimedia/ffmpeg/Makefile
index 3923cc820..ab1beb640 100644
--- a/multimedia/ffmpeg/Makefile
+++ b/multimedia/ffmpeg/Makefile
@@ -289,7 +289,7 @@ endef
 define Package/libffmpeg-custom
 $(call Package/libffmpeg/Default)
  TITLE+= (custom)
- DEPENDS+= @DEVEL +libspeex
+ DEPENDS+= @DEVEL +libopus +libspeex
  VARIANT:=custom
  MENU:=1
 endef
@@ -308,7 +308,7 @@ endef
 define Package/libffmpeg-audio-dec
 $(call Package/libffmpeg/Default)
  TITLE+= (audio)
- DEPENDS+= @DEVEL +libspeex
+ DEPENDS+= @DEVEL +libopus +libspeex
  VARIANT:=audio-dec
 endef
 
@@ -428,6 +428,12 @@ ifeq ($(CONFIG_FFMPEG_CUSTOM_SELECT_adpcm),y)
 
 endif
 
+ifeq ($(CONFIG_FFMPEG_CUSTOM_SELECT_libopus),y)
+  FFMPEG_CONFIGURE+= \
+	--enable-libopus --enable-decoder=libopus \
+
+endif
+
 ifeq ($(CONFIG_FFMPEG_CUSTOM_SELECT_speex),y)
   FFMPEG_CONFIGURE+= \
 	--enable-libspeex --enable-decoder=libspeex \
@@ -454,6 +460,7 @@ ifeq ($(BUILD_VARIANT),audio-dec)
 	$(call FFMPEG_ENABLE,demuxer,$(FFMPEG_AUDIO_DEMUXERS)) \
 	$(call FFMPEG_ENABLE,parser,$(FFMPEG_AUDIO_PARSERS)) \
 	$(call FFMPEG_ENABLE,protocol,$(FFMPEG_AUDIO_PROTOCOLS)) \
+	--enable-libopus --enable-decoder=libopus \
 	--enable-libspeex --enable-decoder=libspeex \
 	--disable-decoder=pcm_bluray,pcm_dvd \
 
-- 
cgit v1.2.3