aboutsummaryrefslogtreecommitdiff
path: root/libs
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-04-25 20:49:11 -0700
committerRosen Penev <rosenp@gmail.com>2020-04-27 15:55:23 -0700
commitc091932a7917e00a826d30a9c1c5ac9f90572ca6 (patch)
tree6aefcfdb91834caccdf1b8a5101d1ff722c60ff9 /libs
parent6002d160a3bfb46849a20870bd544a1026c16d0e (diff)
jsoncpp: add size optimizations
Reduces size slightly. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'libs')
-rw-r--r--libs/jsoncpp/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/libs/jsoncpp/Makefile b/libs/jsoncpp/Makefile
index c63daed6b..0eb1f898f 100644
--- a/libs/jsoncpp/Makefile
+++ b/libs/jsoncpp/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=jsoncpp
PKG_VERSION:=1.9.2
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/open-source-parsers/jsoncpp/tar.gz/$(PKG_VERSION)?
@@ -47,6 +47,11 @@ define Package/jsoncpp/description
convenient format to store user input files.
endef
+MESON_ARGS += \
+ -Db_lto=true
+
+TARGET_LDFLAGS += -Wl,--gc-sections
+
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/include
$(CP) $(PKG_INSTALL_DIR)/usr/include/json $(1)/usr/include/