aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--libs/jsoncpp/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/libs/jsoncpp/Makefile b/libs/jsoncpp/Makefile
index c63daed6b..0eb1f898f 100644
--- a/libs/jsoncpp/Makefile
+++ b/libs/jsoncpp/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=jsoncpp
PKG_VERSION:=1.9.2
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/open-source-parsers/jsoncpp/tar.gz/$(PKG_VERSION)?
@@ -47,6 +47,11 @@ define Package/jsoncpp/description
convenient format to store user input files.
endef
+MESON_ARGS += \
+ -Db_lto=true
+
+TARGET_LDFLAGS += -Wl,--gc-sections
+
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/include
$(CP) $(PKG_INSTALL_DIR)/usr/include/json $(1)/usr/include/