aboutsummaryrefslogtreecommitdiff
path: root/libs
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2019-10-16 18:19:04 -0700
committerGitHub <noreply@github.com>2019-10-16 18:19:04 -0700
commit986f6c110d5c8715870651a9e50ca58d27370b03 (patch)
treeb80c9ac017f20ca0d117a85f20ed144f9fae770c /libs
parent2285913b1aa63ef4ae56e9f04fd75f28ed78c149 (diff)
parent260d4a346afeffec5f7e4818d1179ea8db70420e (diff)
Merge pull request #10168 from neheb/boooooooooooo
boost: Remove several host libraries
Diffstat (limited to 'libs')
-rw-r--r--libs/boost/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/libs/boost/Makefile b/libs/boost/Makefile
index 0d52e70cd..90518c17a 100644
--- a/libs/boost/Makefile
+++ b/libs/boost/Makefile
@@ -13,7 +13,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=boost
PKG_VERSION:=1.71.0
PKG_SOURCE_VERSION:=1_71_0
-PKG_RELEASE:=3
+PKG_RELEASE:=4
PKG_SOURCE:=$(PKG_NAME)_$(PKG_SOURCE_VERSION).tar.bz2
PKG_SOURCE_URL:=@SF/$(PKG_NAME)/$(PKG_NAME)/$(PKG_VERSION) https://dl.bintray.com/boostorg/release/$(PKG_VERSION)/source/
@@ -332,7 +332,7 @@ endef
$(eval $(call DefineBoostLibrary,atomic,system))
$(eval $(call DefineBoostLibrary,chrono,system))
$(eval $(call DefineBoostLibrary,container))
-$(eval $(call DefineBoostLibrary,context,chrono system thread,,!boost-context-exclude))
+$(eval $(call DefineBoostLibrary,context,chrono system,,!boost-context-exclude))
$(eval $(call DefineBoostLibrary,contract,system))
$(eval $(call DefineBoostLibrary,coroutine,system chrono context thread,,!boost-coroutine-exclude))
$(eval $(call DefineBoostLibrary,date_time))
@@ -367,7 +367,7 @@ define Host/Compile
( cd $(HOST_BUILD_DIR) ; \
./bootstrap.sh --prefix=$(STAGING_DIR_HOSTPKG) \
- --with-libraries=atomic,context,date_time,filesystem,headers,program_options,regex,system,thread ;\
+ --with-libraries=context,filesystem,program_options,regex,system ;\
./b2 --ignore-site-config install )
endef