aboutsummaryrefslogtreecommitdiff
path: root/libs
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2019-10-07 11:06:17 -0700
committerRosen Penev <rosenp@gmail.com>2019-10-07 11:07:50 -0700
commit260d4a346afeffec5f7e4818d1179ea8db70420e (patch)
treedcfc75fdbafcf714595deee06df5e1f16cd27081 /libs
parentddd4109c1cc87193f2fd04eda1adb0886226fa67 (diff)
boost: Remove thread dependency from context
thread is only used when the C++ mutex header is missing. AFAIK, this is the case on Windows and not on Linux. Certainly not in OpenWrt. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'libs')
-rw-r--r--libs/boost/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/libs/boost/Makefile b/libs/boost/Makefile
index 70c630856..90518c17a 100644
--- a/libs/boost/Makefile
+++ b/libs/boost/Makefile
@@ -332,7 +332,7 @@ endef
$(eval $(call DefineBoostLibrary,atomic,system))
$(eval $(call DefineBoostLibrary,chrono,system))
$(eval $(call DefineBoostLibrary,container))
-$(eval $(call DefineBoostLibrary,context,chrono system thread,,!boost-context-exclude))
+$(eval $(call DefineBoostLibrary,context,chrono system,,!boost-context-exclude))
$(eval $(call DefineBoostLibrary,contract,system))
$(eval $(call DefineBoostLibrary,coroutine,system chrono context thread,,!boost-coroutine-exclude))
$(eval $(call DefineBoostLibrary,date_time))