aboutsummaryrefslogtreecommitdiff
path: root/libs/libzdb
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2016-01-20 20:30:04 +0100
committerFelix Fietkau <nbd@openwrt.org>2016-01-20 21:56:03 +0100
commit9f8e5aca342c806d1031e063b00a0045e0eb6c57 (patch)
treee9547c4e7c77f1db6e1ea8c9c96b36ee548f641f /libs/libzdb
parentf12aae60ad661a67b45ef4370757fa5236ffffff (diff)
treewide: use $(STAGING_DIR)/host instead of $(STAGING_DIR_HOST), sync with changes in trunk
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
Diffstat (limited to 'libs/libzdb')
-rw-r--r--libs/libzdb/Makefile4
-rw-r--r--libs/libzdb/patches/020-filterh-use-host-built-version.patch2
2 files changed, 3 insertions, 3 deletions
diff --git a/libs/libzdb/Makefile b/libs/libzdb/Makefile
index f3fc66eed..cf17a2cff 100644
--- a/libs/libzdb/Makefile
+++ b/libs/libzdb/Makefile
@@ -67,8 +67,8 @@ define Host/Compile
endef
define Host/Install
- $(INSTALL_DIR) $(STAGING_DIR_HOST)/bin
- $(CP) $(HOST_BUILD_DIR)/tools/bin/filterh $(STAGING_DIR_HOST)/bin/
+ $(INSTALL_DIR) $(STAGING_DIR)/host/bin
+ $(CP) $(HOST_BUILD_DIR)/tools/bin/filterh $(STAGING_DIR)/host/bin/
endef
$(eval $(call HostBuild))
diff --git a/libs/libzdb/patches/020-filterh-use-host-built-version.patch b/libs/libzdb/patches/020-filterh-use-host-built-version.patch
index 74c166a6c..1edfd77b3 100644
--- a/libs/libzdb/patches/020-filterh-use-host-built-version.patch
+++ b/libs/libzdb/patches/020-filterh-use-host-built-version.patch
@@ -14,7 +14,7 @@ diff -rupN libzdb-3.0.orig/Makefile.am libzdb-3.0/Makefile.am
RE2C = @RE2C@
RE2CFLAGS = -b
-FILTERH = ./tools/bin/filterh
-+FILTERH = $(STAGING_DIR_HOST)/bin/filterh
++FILTERH = $(STAGING_DIR)/host/bin/filterh
AM_CPPFLAGS = $(CPPFLAGS) $(DBCPPFLAGS)
AM_CPPFLAGS += -Isrc -Isrc/util -Isrc/net -Isrc/db -Isrc/exceptions