aboutsummaryrefslogtreecommitdiff
path: root/libs/libtheora/Makefile
diff options
context:
space:
mode:
authorW. Michael Petullo <mike@flyn.org>2014-07-17 17:09:57 -0400
committerSteven Barth <steven@midlink.org>2014-07-19 14:08:11 +0200
commit1928e54f228cba7407215f3060fbfc0f0a564749 (patch)
treef5b0b9922b2a1ccc83923925e559cf3a0a7ca66c /libs/libtheora/Makefile
parent204954111f82ce87c849acc32cca14c3142c2e9e (diff)
Copy libtheora package from old repository
Signed-off-by: W. Michael Petullo <mike@flyn.org>
Diffstat (limited to 'libs/libtheora/Makefile')
-rw-r--r--libs/libtheora/Makefile65
1 files changed, 65 insertions, 0 deletions
diff --git a/libs/libtheora/Makefile b/libs/libtheora/Makefile
new file mode 100644
index 000000000..ae258868d
--- /dev/null
+++ b/libs/libtheora/Makefile
@@ -0,0 +1,65 @@
+#
+# Copyright (C) 2008-2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=libtheora
+PKG_VERSION:=1.1.1
+PKG_RELEASE:=1
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=http://downloads.xiph.org/releases/theora/
+PKG_MD5SUM:=292ab65cedd5021d6b7ddd117e07cd8e
+PKG_FIXUP:=autoreconf
+
+PKG_BUILD_DEPENDS:=libvorbis
+
+include $(INCLUDE_DIR)/package.mk
+
+PKG_INSTALL=1
+
+define Package/libtheora
+ SECTION:=libs
+ CATEGORY:=Libraries
+ TITLE:=libtheora
+ URL:=http://xiph.org/theora/
+ MAINTAINER:=W. Michael Petullo <mike@flyn.org>
+ DEPENDS:=+libogg
+endef
+
+define Package/libtheora/description
+Theora is Xiph.Org's first publicly released video codec, intended
+for use within the Foundation's Ogg multimedia streaming system.
+Theora is derived directly from On2's VP3 codec; Currently the
+encoders are nearly identical, but Theora will make use of new
+features supported by the decoder to improve over what is
+is possible with VP3.
+endef
+
+define Build/Configure
+ $(call Build/Configure/Default, \
+ --disable-examples \
+ --disable-oggtest \
+ --disable-vorbistest \
+ --disable-sdltest \
+ )
+endef
+
+define Build/InstallDev
+ $(INSTALL_DIR) $(1)/usr/include/theora/
+ $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/include/theora/* $(1)/usr/include/theora/
+ $(INSTALL_DIR) $(1)/usr/lib/
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/*.{so*,a,la} $(1)/usr/lib/
+ $(INSTALL_DIR) $(1)/usr/lib/pkgconfig/
+ $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/* $(1)/usr/lib/pkgconfig/
+endef
+
+define Package/libtheora/install
+ $(INSTALL_DIR) $(1)/usr/lib/
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/*.so* $(1)/usr/lib/
+endef
+
+$(eval $(call BuildPackage,libtheora))