aboutsummaryrefslogtreecommitdiff
path: root/libs
diff options
context:
space:
mode:
authorW. Michael Petullo <mike@flyn.org>2014-07-17 17:09:57 -0400
committerSteven Barth <steven@midlink.org>2014-07-19 14:08:11 +0200
commit1928e54f228cba7407215f3060fbfc0f0a564749 (patch)
treef5b0b9922b2a1ccc83923925e559cf3a0a7ca66c /libs
parent204954111f82ce87c849acc32cca14c3142c2e9e (diff)
Copy libtheora package from old repository
Signed-off-by: W. Michael Petullo <mike@flyn.org>
Diffstat (limited to 'libs')
-rw-r--r--libs/libtheora/Makefile65
-rw-r--r--libs/libtheora/patches/001-no_docs_tests.patch33
-rw-r--r--libs/libtheora/patches/002-no_sdl_check.patch14
3 files changed, 112 insertions, 0 deletions
diff --git a/libs/libtheora/Makefile b/libs/libtheora/Makefile
new file mode 100644
index 000000000..ae258868d
--- /dev/null
+++ b/libs/libtheora/Makefile
@@ -0,0 +1,65 @@
+#
+# Copyright (C) 2008-2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=libtheora
+PKG_VERSION:=1.1.1
+PKG_RELEASE:=1
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=http://downloads.xiph.org/releases/theora/
+PKG_MD5SUM:=292ab65cedd5021d6b7ddd117e07cd8e
+PKG_FIXUP:=autoreconf
+
+PKG_BUILD_DEPENDS:=libvorbis
+
+include $(INCLUDE_DIR)/package.mk
+
+PKG_INSTALL=1
+
+define Package/libtheora
+ SECTION:=libs
+ CATEGORY:=Libraries
+ TITLE:=libtheora
+ URL:=http://xiph.org/theora/
+ MAINTAINER:=W. Michael Petullo <mike@flyn.org>
+ DEPENDS:=+libogg
+endef
+
+define Package/libtheora/description
+Theora is Xiph.Org's first publicly released video codec, intended
+for use within the Foundation's Ogg multimedia streaming system.
+Theora is derived directly from On2's VP3 codec; Currently the
+encoders are nearly identical, but Theora will make use of new
+features supported by the decoder to improve over what is
+is possible with VP3.
+endef
+
+define Build/Configure
+ $(call Build/Configure/Default, \
+ --disable-examples \
+ --disable-oggtest \
+ --disable-vorbistest \
+ --disable-sdltest \
+ )
+endef
+
+define Build/InstallDev
+ $(INSTALL_DIR) $(1)/usr/include/theora/
+ $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/include/theora/* $(1)/usr/include/theora/
+ $(INSTALL_DIR) $(1)/usr/lib/
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/*.{so*,a,la} $(1)/usr/lib/
+ $(INSTALL_DIR) $(1)/usr/lib/pkgconfig/
+ $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/* $(1)/usr/lib/pkgconfig/
+endef
+
+define Package/libtheora/install
+ $(INSTALL_DIR) $(1)/usr/lib/
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/*.so* $(1)/usr/lib/
+endef
+
+$(eval $(call BuildPackage,libtheora))
diff --git a/libs/libtheora/patches/001-no_docs_tests.patch b/libs/libtheora/patches/001-no_docs_tests.patch
new file mode 100644
index 000000000..4a45b8b5b
--- /dev/null
+++ b/libs/libtheora/patches/001-no_docs_tests.patch
@@ -0,0 +1,33 @@
+diff -urN libtheora-1.1.1/Makefile.am libtheora-1.1.1.new/Makefile.am
+--- libtheora-1.1.1/Makefile.am 2009-07-14 01:55:02.000000000 +0200
++++ libtheora-1.1.1.new/Makefile.am 2012-12-05 14:21:06.103521554 +0100
+@@ -8,7 +8,7 @@
+ EXAMPLES_DIR =
+ endif
+
+-SUBDIRS = lib include doc tests m4 $(EXAMPLES_DIR)
++SUBDIRS = lib include m4 $(EXAMPLES_DIR)
+
+
+ # we include the whole debian/ dir in EXTRA_DIST because there's a problem
+diff -urN libtheora-1.1.1/Makefile.in libtheora-1.1.1.new/Makefile.in
+--- libtheora-1.1.1/Makefile.in 2009-10-01 20:04:07.000000000 +0200
++++ libtheora-1.1.1.new/Makefile.in 2012-12-05 14:21:18.239521864 +0100
+@@ -164,7 +164,7 @@
+ @THEORA_ENABLE_EXAMPLES_TRUE@EXAMPLES_DIR = examples
+ @THEORA_ENABLE_EXAMPLES_FALSE@EXAMPLES_DIR =
+
+-SUBDIRS = lib include doc tests m4 $(EXAMPLES_DIR)
++SUBDIRS = lib include m4 $(EXAMPLES_DIR)
+
+ # we include the whole debian/ dir in EXTRA_DIST because there's a problem
+ # with autotools and HFS+ MacOSX file systems that caused debian/Makefile.am
+@@ -200,7 +200,7 @@
+ missing mkinstalldirs theora-uninstalled.pc.in theora.pc.in \
+ theoradec-uninstalled.pc.in theoradec.pc.in \
+ theoraenc-uninstalled.pc.in theoraenc.pc.in
+-DIST_SUBDIRS = lib include doc tests m4 examples
++DIST_SUBDIRS = lib include m4 examples
+ all: config.h
+ $(MAKE) $(AM_MAKEFLAGS) all-recursive
+
diff --git a/libs/libtheora/patches/002-no_sdl_check.patch b/libs/libtheora/patches/002-no_sdl_check.patch
new file mode 100644
index 000000000..a1e7256b4
--- /dev/null
+++ b/libs/libtheora/patches/002-no_sdl_check.patch
@@ -0,0 +1,14 @@
+--- libtheora-1.1.1/configure.ac 2009-10-01 20:00:33.000000000 +0200
++++ libtheora-1.1.1.new/configure.ac 2012-12-05 14:22:26.319523608 +0100
+@@ -313,11 +313,6 @@
+ dnl check for SDL
+ HAVE_SDL=no
+
+-AM_PATH_SDL(,[
+- HAVE_SDL=yes
+- SDL_LIBS=`$SDL_CONFIG --libs`
+-],AC_MSG_WARN([*** Unable to find SDL -- Not compiling example players ***]))
+-
+ dnl check for OSS
+ HAVE_OSS=no
+ AC_CHECK_HEADERS([sys/soundcard.h soundcard.h machine/soundcard.h],[