aboutsummaryrefslogtreecommitdiff
path: root/libs/libpsl/patches/020-iconv.patch
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2022-06-09 15:38:17 -0700
committerRosen Penev <rosenp@gmail.com>2022-06-10 14:10:25 -0700
commit90b64f2bd29156671b0975f0d0ada51b6aaa7804 (patch)
tree9d965bede5971752ef5bccf161db62a21543ff19 /libs/libpsl/patches/020-iconv.patch
parent2fd7ee49a53ef2ebf11c703a30f2316692dde05d (diff)
libpsl: use iconv dependency
Removed need for manual iconv handling. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'libs/libpsl/patches/020-iconv.patch')
-rw-r--r--libs/libpsl/patches/020-iconv.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/libs/libpsl/patches/020-iconv.patch b/libs/libpsl/patches/020-iconv.patch
new file mode 100644
index 000000000..63c9c752f
--- /dev/null
+++ b/libs/libpsl/patches/020-iconv.patch
@@ -0,0 +1,29 @@
+--- a/meson.build
++++ b/meson.build
+@@ -20,6 +20,7 @@ libicu_dep = notfound
+ libidn_dep = notfound
+ libunistring = notfound
+ networking_deps = notfound
++libiconv_dep = notfound
+
+ # FIXME: Cleanup this when Meson gets 'feature-combo':
+ # https://github.com/mesonbuild/meson/issues/4566
+@@ -86,6 +87,7 @@ endif
+ if libidn2_dep.found() or libidn_dep.found()
+ # Check for libunistring, we need it for psl_str_to_utf8lower()
+ libunistring = cc.find_library('unistring')
++ libiconv_dep = dependency('iconv')
+ endif
+
+ if host_machine.system() == 'windows'
+--- a/src/meson.build
++++ b/src/meson.build
+@@ -19,7 +19,7 @@ cargs = [
+ libpsl = library('psl', sources, suffixes_dafsa_h,
+ include_directories : [configinc, includedir],
+ c_args : cargs,
+- dependencies : [libidn2_dep, libidn_dep, libicu_dep, libunistring, networking_deps],
++ dependencies : [libidn2_dep, libidn_dep, libicu_dep, libunistring, networking_deps, libiconv_dep],
+ version: lt_version,
+ install: true,
+ )