aboutsummaryrefslogtreecommitdiff
path: root/libs/libpsl
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2022-06-09 15:38:17 -0700
committerRosen Penev <rosenp@gmail.com>2022-06-10 14:10:25 -0700
commit90b64f2bd29156671b0975f0d0ada51b6aaa7804 (patch)
tree9d965bede5971752ef5bccf161db62a21543ff19 /libs/libpsl
parent2fd7ee49a53ef2ebf11c703a30f2316692dde05d (diff)
libpsl: use iconv dependency
Removed need for manual iconv handling. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'libs/libpsl')
-rw-r--r--libs/libpsl/Makefile4
-rw-r--r--libs/libpsl/patches/020-iconv.patch29
2 files changed, 30 insertions, 3 deletions
diff --git a/libs/libpsl/Makefile b/libs/libpsl/Makefile
index c9a047d8b..3f3b9e04d 100644
--- a/libs/libpsl/Makefile
+++ b/libs/libpsl/Makefile
@@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=libpsl
PKG_VERSION:=0.21.1
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://github.com/rockdaboot/libpsl/releases/download/$(PKG_VERSION)
@@ -40,8 +40,6 @@ MESON_ARGS += \
-Druntime=libidn2 \
-Dbuiltin=libidn2
-TARGET_LDFLAGS += -liconv
-
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/include $(1)/usr/lib $(1)/usr/lib/pkgconfig
$(CP) $(PKG_INSTALL_DIR)/usr/include/libpsl.h $(1)/usr/include/
diff --git a/libs/libpsl/patches/020-iconv.patch b/libs/libpsl/patches/020-iconv.patch
new file mode 100644
index 000000000..63c9c752f
--- /dev/null
+++ b/libs/libpsl/patches/020-iconv.patch
@@ -0,0 +1,29 @@
+--- a/meson.build
++++ b/meson.build
+@@ -20,6 +20,7 @@ libicu_dep = notfound
+ libidn_dep = notfound
+ libunistring = notfound
+ networking_deps = notfound
++libiconv_dep = notfound
+
+ # FIXME: Cleanup this when Meson gets 'feature-combo':
+ # https://github.com/mesonbuild/meson/issues/4566
+@@ -86,6 +87,7 @@ endif
+ if libidn2_dep.found() or libidn_dep.found()
+ # Check for libunistring, we need it for psl_str_to_utf8lower()
+ libunistring = cc.find_library('unistring')
++ libiconv_dep = dependency('iconv')
+ endif
+
+ if host_machine.system() == 'windows'
+--- a/src/meson.build
++++ b/src/meson.build
+@@ -19,7 +19,7 @@ cargs = [
+ libpsl = library('psl', sources, suffixes_dafsa_h,
+ include_directories : [configinc, includedir],
+ c_args : cargs,
+- dependencies : [libidn2_dep, libidn_dep, libicu_dep, libunistring, networking_deps],
++ dependencies : [libidn2_dep, libidn_dep, libicu_dep, libunistring, networking_deps, libiconv_dep],
+ version: lt_version,
+ install: true,
+ )