aboutsummaryrefslogtreecommitdiff
path: root/libs/libftdi1
diff options
context:
space:
mode:
authorEneas U de Queiroz <cote2004-github@yahoo.com>2018-07-31 17:55:22 -0300
committerEneas U de Queiroz <cote2004-github@yahoo.com>2018-07-31 18:12:28 -0300
commit0e9e0607758311f15bb1b481ee91ae12bc0fc92b (patch)
treee66d1a175ed70c528b9cfcb11ee97f7786f4fea3 /libs/libftdi1
parent7c21db5fbcbf6e60f40224fb7f2552cbb3fd9155 (diff)
libftdi1: Fix compilation with cmake 3.12
Applied a patch submitted upstream that fixes a compilation error with cmake >= 3.12 Error: Unable to find 'swig.swg' [...] 'python.swg' Signed-off-by: Eneas U de Queiroz <cote2004-github@yahoo.com>
Diffstat (limited to 'libs/libftdi1')
-rw-r--r--libs/libftdi1/Makefile2
-rw-r--r--libs/libftdi1/patches/101-use-findSWIG.patch11
2 files changed, 12 insertions, 1 deletions
diff --git a/libs/libftdi1/Makefile b/libs/libftdi1/Makefile
index 35c3bf006..fddf40341 100644
--- a/libs/libftdi1/Makefile
+++ b/libs/libftdi1/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=libftdi1
PKG_VERSION:=1.4
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=http://www.intra2net.com/en/developer/libftdi/download/
diff --git a/libs/libftdi1/patches/101-use-findSWIG.patch b/libs/libftdi1/patches/101-use-findSWIG.patch
new file mode 100644
index 000000000..91542ca28
--- /dev/null
+++ b/libs/libftdi1/patches/101-use-findSWIG.patch
@@ -0,0 +1,11 @@
+--- a/python/CMakeLists.txt
++++ b/python/CMakeLists.txt
+@@ -3,7 +3,7 @@ option ( LINK_PYTHON_LIBRARY "Link again
+
+ if ( PYTHON_BINDINGS )
+ # workaround for cmake bug #0013449
+- if ( NOT DEFINED CMAKE_FIND_ROOT_PATH )
++ if ( NOT DEFINED CMAKE_FIND_ROOT_PATH OR CMAKE_VERSION VERSION_GREATER_EQUAL 3.0.0 )
+ find_package ( SWIG )
+ else ()
+ find_program ( SWIG_EXECUTABLE NAMES swig2.0 swig )