aboutsummaryrefslogtreecommitdiff
path: root/libs/libftdi1/patches/101-use-findSWIG.patch
diff options
context:
space:
mode:
Diffstat (limited to 'libs/libftdi1/patches/101-use-findSWIG.patch')
-rw-r--r--libs/libftdi1/patches/101-use-findSWIG.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/libs/libftdi1/patches/101-use-findSWIG.patch b/libs/libftdi1/patches/101-use-findSWIG.patch
new file mode 100644
index 000000000..91542ca28
--- /dev/null
+++ b/libs/libftdi1/patches/101-use-findSWIG.patch
@@ -0,0 +1,11 @@
+--- a/python/CMakeLists.txt
++++ b/python/CMakeLists.txt
+@@ -3,7 +3,7 @@ option ( LINK_PYTHON_LIBRARY "Link again
+
+ if ( PYTHON_BINDINGS )
+ # workaround for cmake bug #0013449
+- if ( NOT DEFINED CMAKE_FIND_ROOT_PATH )
++ if ( NOT DEFINED CMAKE_FIND_ROOT_PATH OR CMAKE_VERSION VERSION_GREATER_EQUAL 3.0.0 )
+ find_package ( SWIG )
+ else ()
+ find_program ( SWIG_EXECUTABLE NAMES swig2.0 swig )