aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorMarcus Folkesson <marcus.folkesson@gmail.com>2024-02-12 15:57:30 +0100
committerChristian Marangi <ansuelsmth@gmail.com>2024-04-18 16:29:34 +0200
commiteb35a3be13d98f306454657b0326822cf3029b29 (patch)
tree8fbff8f9370f7fba735ab06bca4e2cb7b617b462 /lang
parent436e462c6405e9bcbdd2756b596d32c763fcd7ee (diff)
python-jinja2: create /host target
Make the python-jinja2/host target available for the build environment to be used with e.g. the PKG_BUILD_DEPENDS list. This is needed for an upcoming package (libcamera). Signed-off-by: Marcus Folkesson <marcus.folkesson@gmail.com>
Diffstat (limited to 'lang')
-rw-r--r--lang/python/python-jinja2/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/lang/python/python-jinja2/Makefile b/lang/python/python-jinja2/Makefile
index 76ebb2334..e7514ff13 100644
--- a/lang/python/python-jinja2/Makefile
+++ b/lang/python/python-jinja2/Makefile
@@ -15,10 +15,13 @@ PKG_MAINTAINER:=Michal Vasilek <michal.vasilek@nic.cz>
PKG_LICENSE:=BSD-3-Clause
PKG_LICENSE_FILES:=LICENSE.rst
PKG_CPE_ID:=cpe:/a:pocoo:jinja2
+HOST_BUILD_DEPENDS:= python-markupsafe/host
include ../pypi.mk
include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/host-build.mk
include ../python3-package.mk
+include ../python3-host-build.mk
define Package/python3-jinja2
SECTION:=lang
@@ -43,3 +46,4 @@ endef
$(eval $(call Py3Package,python3-jinja2))
$(eval $(call BuildPackage,python3-jinja2))
$(eval $(call BuildPackage,python3-jinja2-src))
+$(eval $(call HostBuild))