aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorMarcus Folkesson <marcus.folkesson@gmail.com>2024-02-12 16:04:09 +0100
committerChristian Marangi <ansuelsmth@gmail.com>2024-04-18 16:28:59 +0200
commit436e462c6405e9bcbdd2756b596d32c763fcd7ee (patch)
treef94b7464a1797041fc61bd00194229e951404e95 /lang
parent660aa8091f1551da5ee071a4f49e92cd3e73a4c4 (diff)
python-yaml: create /host target
Make the python-yaml/host target available for the build environment to be used with e.g. the PKG_BUILD_DEPENDS list. This is needed for an upcoming package (libcamera). Signed-off-by: Marcus Folkesson <marcus.folkesson@gmail.com>
Diffstat (limited to 'lang')
-rw-r--r--lang/python/python-yaml/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/lang/python/python-yaml/Makefile b/lang/python/python-yaml/Makefile
index 92ac32841..8a62c7f36 100644
--- a/lang/python/python-yaml/Makefile
+++ b/lang/python/python-yaml/Makefile
@@ -20,10 +20,13 @@ PKG_LICENSE_FILES:=LICENSE
PKG_CPE_ID:=cpe:/a:pyyaml:pyyaml
PKG_BUILD_DEPENDS:=python-cython/host
+HOST_BUILD_DEPENDS:=python-cython/host
include ../pypi.mk
include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/host-build.mk
include ../python3-package.mk
+include ../python3-host-build.mk
define Package/python3-yaml
SECTION:=lang
@@ -43,3 +46,4 @@ PYTHON3_PKG_BUILD_VARS:=PYYAML_FORCE_LIBYAML=1
$(eval $(call Py3Package,python3-yaml))
$(eval $(call BuildPackage,python3-yaml))
$(eval $(call BuildPackage,python3-yaml-src))
+$(eval $(call HostBuild))